Tech support from hell!

I’ve been in the AV business for almost 30 years and have rarely seen such incompetant tech support for such a simple process.

I picked up a new SpotCam wired for an existing Ring client but the camera didn’t work so tech support decided to replace it. After waiting 10 days the replacement arrived and I schedule to install of the replacement but when I got there and opened the bo it was the wrong camera type despite explicitly telling the tech which camera I had, I gave them the MAC so they could verify the camera type, etc but now I wasted an 1.5 hours. Of course I’m an ■■■■■ for not checking the box before leaving the shop so shame on me.

I go back to the shop call tech support again and this person was pretty lost, spent a 1/2 explaining over and over what I needed and she said she understood but apparently didn’t cuz later the client not myselft got an email reuesting further clarification so I responded in exact detail. A week goes by and no response so I send another email asking if they got my email and if everything was understood but again a week goes by and no response so I send another email. FYI, I’m hardly ever in the office so I’m not immediately on top of things cuz I got a lot going on besides a stupid Ring camera. Again no response so when I had a chance and in my office I called and this time the tech I talked with said they didn’t respond to my emails cuz it didn’t come in from the client’s email address, wtf! How many people have multiple email accounts and what about AV dealers with clients? So another two weeks waisted but this tech seem competent told me explicitaly she was going to make sure they send the right SpotCam Wired device, I told her I forgave Ring for there stupid policy of not answering emails from non client or case connected email addresses and I waited for the new replacement to arrive. Ten days or so later it arrives and I put the bo on the shelf until I had a chance to schedule the installation, maybe 3 days later but this time before scheduling a morning for the install I opened the box first and guess what, the same freaking wrong camera, another SpotCam battery, WTF! So I got to call tech support again and go through this whole thing again, this time giving them the MAC addresses of the replacement cameras I have piling up on my desk.

We’ll see what comes in but so far it’s been over a month dealing with what should be such a simple process, I’ve been on the phone probably an hour in total, out to the job once with the wrong camera, out to the job with the initial faulty camera so I’m at least looking at 4 hours of lost labor time and vehicle costs that’s not billable. Ring isn’t something I normally recommend except for clients with budget constraints but when products start to cost me time and money I start to get pis sed. Good companies would at least feel bad and comp me a free device to keep me selling their products but I don’t think Ring is an old school company like that since their main avenue is direct client sales so they apparently could give two sh its about keeping AV dealers happy.

After all this BS I then get this email:

"This email is to confirm that a replacement Spotlight Cam Battery has been ordered for you. This request will be processed and shipped as soon as possible. "

They’re going to send me yet another SpotLight Cam Battery and not the wired camera they keep insisting they are going to send me which is want I keep asking for. They are idiots! Guess I get to waste more time and call them again.

According to the latest tech guy I talked with the email they sent is wrong and they will in deed be sending a Spotlight Cam wired. I guess we’ll see in a week or so. Just another 1/2 hour of my life they wasted that I can’t bill for. Just wait until I get on the various AV forums I frequent, we love to spread the word on products and manufactureres to avoid and which products and companies will work as adverstised, according to specs and with good support.

Sorry to hear about your poor experience! If I were you I would’ve simply asked for a supervisor.

Finally got the correct replacement, installed in seconds and it worked just fine. Seems like each time I install Ring devices for clients there’s always one device out of the bunch that simply shipped defective from the factory and each time equals wasted time troubleshooting at the jobsite before determining it’s a Ring issue, then wasting time with their tech support and finally wasting time going back to the job to install the replacement device that works immediately.

I install a lot more Axis cameras and have never had one nadf rom the factory but they’re a higher end brand. I wonder what the quality control level of Nest cameras is and some of the other lower quality consumer products are?

Yep. Just installed a bunch of contact sensors and of course one is defective :frowning:
Gotta jump through all the hoops now…