Struggling to connect Video Doorbell to my network

I am installing my first Video Doorbell. With the App, I get as far as choosing my network and entering a password. Then I just get a failed page, and the light keeps spinning.

I am trying to connect with a BT Smart Hub. I have found various tips online so at the moment…

  • I have separate 2.4 GHz and 5 GHz connections, and can confirm the doorbell only sees the 2.4GHz
  • The “Smart setup” is turned off.
  • The SSID only contains alpha characters
  • Security type is WPA2
  • I have tried specifying channels 1, 6 and 11 (the only ones available).
  • The hub has a “wireless mode” which defines the 802.11 protocols that are supported - I have tried all 3 options
  • I have checked the hub event log and that shows no entry after I try a doorbell setup
  • I have done a factory reset on the doorbell (holding the orange button for >30 seconds)
  • I also tried connecting to a hotspot on my phone with the same result - The network appears in the list, but does not connect.
  • My wifi analyser shows I am getting a strong signal and there are no other strong signals in the areas.
  • At the point of entering the password, the App has some advanced options - I noticed that these seem to default to a static IP entry. I have tried selecting DHCP and tried entering a valid static IP configuration.

I have concluded my unit is broken! Is there anything I have missed? Thank you community :slight_smile:

Hey @MortimerCat. Great work and thank you for detailing everything you have done! This may help other neighbors in the future try out these options as well to see if they fix their concern. Bravo indeed!

In regards to additional troubleshooting steps, it looks like you have exhausted nearly everything you can do on your end. If you can, please reach out to our support team here via call so they can work with you on this to help reach a resolution that works. Feel free to come back and let us know what the advanced technical support agents were able to do for you. :slight_smile:

Hi I have had the same problem and done the majority of what you have done, been on the phone to rin for a long time and spent most of the day on this, but still can’t get it to work. Did you resolve your problem? Many thanks

Experiencing the same problem on my video doorbell pro after it being perfectly connected for about 2 weeks. Any advice come from technical support or do I need to replace the unit?

Can’t seem to complete