Stickup Cam stops functioning every couple days

I have 2 stickup Cam (Battery) that are both experiencing the exact same issue. I can setup sucessfully and deploy. They have very good wifi signals and completely full battery. Every couple days it stops all functions, the light turns solid blue. Pulling the battery and resetting does not help. When I do that it enters setup mode everytime. After setup, it keeps saying updating software and it takes up to 1 hour or more. It is beyond anoying having to setup continously and have it keep updating software over and over. None of the other cams I have do this. (Spotlight cam, indoor cam). Are there any issues related to the 3rd gen stickup cam’s. I find it odd that they both do the exact same thing.

Hey @pacerlink! Thank you for sharing your experience in detail. With these devices behaving similarly, the best thing to check first is the network. Signal strength is certainly important, however, network speeds, distance, and router efficiency are also factors to consider.

If all of the above is sufficient for a dependable connection, and this concern persists, our support team will be happy to go through advanced troubleshooting steps with you. :slight_smile:

I have a similar issue with my Stick Up. It worked perfect for at least a year, now recently I cannot get Live Midd to work. It is still catching motion activity, however, but delayed. Could this be WiFi related? How do I check for proper signal strength?

I can share some of this experience. Good WiFi, Good battery. The camera never fails but does have issues with video. Going “live” either times out or fails completely. Motion alerts seem to be working well. For the most part I am happy with the camera but will not be buying another unless this issue can be resolved.

Also, I have a Ring Doorbell and that shows none of these issues and the stickup cam is physically closer to the router. No other devices show this behavior when used in the area near the stickup cam.

Good question @Jimmyc966! The signal strength can be confirmed in the Ring app via Device Health. Open the Ring app > tap menu (top left) > select devices > choose device > tap Device Health. Our Community post on RSSI has some great tips for improving signal, and what is considered good RSSI.

@vascott1, thank you for the breakdown of symptoms. While checking wifi is the best first step, if network signal and resources prove to be sufficient for video connection, removing and reinstalling the application could help to optimize functionality between it and your mobile device. Variables such as bluetooth, VPN, cellular data vs wifi, and other apps open in the background could also interfere with mobile device connection.

I might suggest you check the strength of the wi-fi signal on the network assigned to each camera. Try setting each camera to a different network, so that both are not on the same network, in the event that one wi-fi network is being overloaded. Just a thought.

I continue to have this issue with ONLY the stickup cam’s. It is not a WiFi signal level issue as one is less than 10’ from an AP. It is not a network speed issue as the speed is measured at over 40mbps. The network is a Cisco 9300 switch through Cisco 3802 WAP’s, so the network is ruled out. If it were network related the other 3 Non Stick-up cams would have seen issues, but do not. I’m at a point where I am rebooting the two stick-up cams daily. They up and drop off line and never rejoin. I have tried using an SSID with no encryption just to be sure, no good.

Hi,

There are serveral people reporting this over the last week.

I’m not sure if Ring Community support link issues together but I think it would be best to call Ring support as they can escalate to advanced technical team / engineering team.

I have the same issue and they’ve ordered a replacement. Not sure if this will help as it’s a brand new device and numerous people are reporting the issue.

https://community.ring.com/t5/Security-Cams/Stick-Up-Cam-Battery-Not-Responding/td-p/37927

https://community.ring.com/t5/Security-Cams/Stick-Up-Cam-repeatedly-disconnecting/td-p/40505

https://community.ring.com/t5/Security-Cams/Stick-Up-Cameras-Simply-Just-Not-Working/td-p/40238

https://community.ring.com/t5/Security-Cams/Stick-up-cam-becomes-unresponsive/td-p/41106

2 Likes