Stickup Cam Elite Gen2, unable to enter Setup Mode

As one of my 6 StickUp Cam Elite (gen2) did disconnect from PoE, I tried to reset. But NOTHING worked. The Blue LED is constantly on.

Neither Unplugging and reconnecting it did change anything, nor pressing the Orange Button once, twice or holding for 20 Seconds until LED goes off. Blue LED comes back on but I cant get it to Ble Blinking.

Any sugestions?

Same here. Last night my elite cam stopped working. Solid blue light and can’t enter setup mode.

Tried suggestions for hard reset, etc, but can’t enter setup mode.

1 Like

While Ring is great if it works, and if you get local US-Support, they are ver ynice, it is one of the most horrible instabile platform I have experienced, and I’m so mad at myself having bought with 100s of dollars into it.
The Problem about the StickUp Cam is KNOWN!!!
But they don’t care putting it on their status Page. I wasted 2 Hours as I’m 4000 Miles away with a Contractor at my expense to fix it. I finally had someone on the phone, and all the same crap (20 Secons holding Organge Button, lets try 30 Seconds now) and every other standard Procedure was tried out. Wasting more of my time and also wasting Phone Supports time. LUCKILY the Agent said, well let me call “Engineering”… After like 5 Minutes he came back and said. OH there is a Problem with a firmware Upgrade they are aware, I would get a call or E-Mail in 24-48 Hours they should have it fixed.
I’m sorry RING, WHY ARE YOU SO EVIL TO YOUR CUSTOMERS??? WHY DO YOU NOT POST THAT ON STATUS.RING.COM even now 24 hours later nothing is noted there, I told that the same Agent he should tell them to put it on the Status page, it would have saved me lots of time and money.
Sorry Ring, some stuff you try to do is so nice and modern but then you screw up at BASIC STUFF LIKE THIS!!!
So to anyone having the same problem… sit and wait. MAYBE they will fix it, BUT FOR SURE THEY WILL NOT PUT IT ON THE STATUS PAGE!

1 Like

So root cause is a firmware update?

Do we know what time it went out? Is the expectation that eventually it will complete and the camera will start to function again or is it bricked?

I talked to support and they are sending me a replacement camera.

Yes that what “Engeneering” told my Ring Support Rep. I have still no anser for them so far, no promised E-Mail or PhoneCall or anything. And the page still claims all is wonderful operational.
I’m so upset, I took the decission I’m done with their incapable useless products that work only in 50% of the cases I had so much agrevation I wasted so much time and money with a 4000 Miles away Handy Man to test their useless “press orange button, wait press twice, press 20 Seconds whatever” troubleshooting.
I will sell all Cameras who ever wants that junk. I have 6 Stick Up Cam Elites Gen2 PoE for sale and a Video Doorbell Pro.
I will replac ethem with Ubiquity Cameras and Cloudkey2 like I have in other Locations, never a problem all works smooth.