Stick-Up Cam Not Recognizing Wired

Is there something we need to do to reset it? I still get the message that it’s not plugged into power. I don’t have time to call right now but was hoping your team had some direction on the process. Thanks.

So I called support and was escalated to a top tier support level supposedly. They were unable to help and are now sending a Ring adapter to see if that works. I’m currently using 3rd party adapters which worked perfectly find for 3 months. I refuse to buy new adapters since the ones I have should work and also have much longer wires than the official Ring versions. This better not be a ploy by Ring to force people to buy Ring brand accessories.

@Mark_CT Since the Community is a public forum, we aren’t able to view any account or device details. That’s why some issues might require the assistance of our support team, as they can take a closer look. It’s good to hear that support is sending out a new adapter in an effort to resolve this.

I am having the same issue… I recently installed two new cameras using the same stick up cam gen 3 and the same 3rd party power adapters as the first two cameras I installed over a year ago… the older cameras do not have this issue so I pulled the battery on one of my older cameras and is still working with no issues or warnings even though it’s only power source is the same 3rd party power adapter so it’s clearly not the adapter. The only difference between the first two cameras and the two new cameras is the software update the two new cameras ran during the installation so I think it’s safe to say it’s a software issue… The two new cameras work fine and are 100% charged, but is very annoying to keep seeing “camera stopped receiving power”

1 Like

It is getting ridiculously frustrating at this point.