Solved: Connection Problem with Telstra Smart Modem

I’m posting this in case it helps save someone the hours I spent trying to get my Ring Doorbell 2 to connect to the internet via a Telstra Smart Modem Gen2.

A feature of this modem is that it contains a SIM card and will connect to the mbl network, if the hard-wired NBN network goes down. It is often the case that the modem arrives for a new installation before the NBN line is physically connected, in which case the modem operates using the mbl network from the get-go, until the NBN cabling is completed.

Out of the box, the modem in mbl mode connects to a Ring security floodlamp (and perhaps other devices…I don’t know) without any problems BUT it won’t allow the Ring 2 doorbell to connect to the i/net: you will hang up with two lights on the left of the ring flashing and an error message.

The solution is to go into the management portal of the Telstra Gen2 Smart Modem and go Advanced/Internet/LTE. Scroll down to Mobile Configuration and find a window labelled “PDP Type”. The default you are likely to see is “IPV6”…which is blocking the Ring2. Instead, select (“IPv4v6”). Save, then re-start your install process and it should go smoothly.

2 Likes

Jubilee! OMG! Thank you! Thank you!

Since getting my new Telstra Smart Modem Gen 2 with it accessing via mobile (since the NBN is still not connected) I have spent SO MANY weekend HOURS on this, plus a 3.5 hour customer support call, that has all ended in failure!

Your Pro Tip on this new Telstra Smart Modem Gen 2 enabled me to get live again. Quick note that I had to restart the Telstra modem after resetting the PDP Type in order for it to take affect. After that - smooth sailing :slight_smile:

Cheers!

2 Likes

Mate, you are a legend, this fixed my issue too, wish I found your post earlier

1 Like