Solid Red Light Stick Up Battery Cam

My camera is working fine, but recently when it’s not activated the LED is solid red. The charge is 76% so that’s not the problem. I have checked the website for LED states, but solid red is not mentioned. Any ideas?

Ken

Hi @Senex! Is this solid red light remaining on and solid? Activating your Cam’s siren, failing setup, or resetting your Camera are instances when a red light might show, but these would usually blink or go off after time. Feel free to include an image example of what light is showing on this Camera.

Thanks for the reply. The red light (see attached) is on all the time when not recording. When recording, the light shines pinkish (red and blue at same time?). The attached image may not be of good enough quality to show it, but it’s quite obvious “in real life”.

Second image attached.

Thank you for those image examples, @Senex. That helped to confirm it was indeed the primary LED indicator. With this being solid in pattern and happening in the manner it is, try performing a reset by holding the reset button for 20 seconds. This will clear up any error that might have happened with the LED status. As you mentioned the Camera working as intended otherwise, if this LED indicator persists the best next step will be to reach out to our support team for a closer look at the device. Please read our response to COVID-19 here to see how to contact support. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times.