Solid Blue ring while charging then nothing

Ring stopped working a couple of weeks ago, was working fine. I pulled it off and tried to set up with home wifi again (this has not changed). Pressing the orange button on the back did nothing, app on my phone could not connect to it and the ring was not on the list of wifi hot spots. I decided to try and plug it in to see if battery needed a recharge. When plugged in I get a solid blue ring not the white ring flashing as charging progressed. I left the unit on the charge for 4 hours (plugged into a wall outlet). When I unplugged it and tried to press the orange button I get no change, the ring doesn’t flash or light up at all. If I hold the orange button down for 20 seconds the ring flashes once a white ring and that is all it does. I am starting to think this unit might be dead? Any suggestions?

Hi @Hobanwash. With all the troubleshooting steps that you’ve done, you should have been able to get your Doorbell to enter setup mode. Since you’ve had no luck, I would reach out to our support team for further assistance. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Let us know how support was able to help you!