Snapshot feature not showing on timeline

Hi @MathewE. We do not have any updates to share at this time. When we have anything to share regarding your Snapshots not appearing on the Event History Timeline, we will be sure to share it in this thread. In the meantime, the marked solution contains all of the relevant information we have available.

Online I was reading that snapshots are supposed to be available if you swipe left from/on the live camera view?? But that doesn’t work either! I followed everything and mine is not battery powered so definitely not an issue there. Why do companies always want to pass the buck?? This is YOUR issue obviously, you should fix it asap!

Hi @RenB. If you have tried the troubleshooting suggestions in the marked solution and your Snapshots are still not showing up on your Event History Timeline, please follow up with our support team so they can investigate this further with you. The concern may be network-related, and could require more advanced troubleshooting support. You can give our support team a call at one of the numbers available here.

My SNAPSHOT is NOT working either! I’ve turned it off and back on and done everything Ring suggests but basically it looks like this feature simply doesn’t work. My “History” shows nothing but motion detects even though I’ve tried using 5-14-60 minutes snapshot settings. I find it frustrating that Ring seems to be washing their hands of the issue… why not just remove it from the Settings option then.

You need to use the timeline view in order to see the snapshots. If you’re viewing the history through the Event History section on the device or by hitting the History button on the main app page you won’t be able to see the snapshots there.

1 Like

Exact same issue here. Absolutely NO snapshots being recorded on either the Ring doorbell or Spotlight camera. Troubleshooted as suggested by Ring support and all the other forum users and no resolution. This issue should have been escalated to the technical team to put a fix in and and push it out to all devices. Disappointing customer service.

Probably not what anyone here is looking for but I found this forum when I was searching for why I couldn’t find my snapshot section to review what has happened today.

A message above said about not going to the event history so I went to the live view and tried everything I could to find what I needed.

Ended up hitting end live view and it then came up with my time line including all snapshots.

Not sure if this helps anyone out or not and I don’t usually post on forums etc. other than Google reviews but wanted to share this…

Scouring the internet for ‘snapshots not working’ and found this. I’m assuming there’s been no update? Tried all suggestions and have a Protect Plus Plan.