Snapshot Capture cut off the beginning of all recorded videos

I’m going to detail the problems enabling Snapshot Capture caused on 2 of my 5 cameras in case others have this issue. This will be a long post to get my points and details across.

To start, I have 5 Ring cameras, all wired. The RSSI rating is typically around 35 - 50. I’ve confirmed with Ring tier 2 support my firmware is up to date on all devices. My (Android) app version is also up to date–3.21.1 as of this writing. My Doorbell Pro power is excellent (almost always over 4,000mV ). My WiFi is quite strong and fast, and nothing has recently changed in my network. Finally, my motions zones of all my cameras have not been adjusted, nor were the sensitivty settings touched. The below problem has nothing to do with motion notifications, or the Ring app (wife and I both have the same version of the app installed, using the same account).

Let me also preface this writing by saying all of my recorded video lengths, since I’ve had these cameras has always consistently been between 1:04 to 1:08 seconds in length. For example, if I leave my house to walk down my driveway and get my mail: the recorded video begins just before you see me open my front door. It gets me walking out of my front door, and the whole way down my driveway.

On New Years Eve I noticed I now had the Snapshot Capture feature available on all my cameras. I was thrilled to finally enable this, so I did so on all 5 cameras.

**The Problems: ** 2 days after enabling Snapshot, I noticed my Doorbell Pro no longer correctly captured motion events. It was missing the start of the motion that caused the motion event; that of which that caused the camera to record. I was no longer getting people approaching my door, or our cars pulling into the driveway. The recorded video would begin AFTER the cars were already parked or as a person was already at my door, rather than approaching.

I let this go for a few days with no improvment, then called into support on Sat 1-4-20. Prior to calling support I rebooted my router and modem, just because it’s something that should always be attempted first. While on hold, awaiting to speak with tier 2 support, I decided I’d try rebooting the DB Pro by holding in the reset button for 30 seconds, BUT, I intentionally never went back into setup mode to re-add the DB Pro. I only allowed it to fully reboot. Rebooting the Pro temporarily fixed the issue. The Pro was again capturing the FULL motion event, start to finish like it always had worked for months prior. I conveyed this info to the tier 2 support analyst, and we called it a night, and it’s fixed.

2 days later, again, on Mon 1-6-20 the exact problem returned on the DB Pro after working fine since the last reboot. Without calling into support, I again rebooted the DB Pro using the above method. This again fixed the problem.

The next day on 1-7-20, my Wired Gen 2 Stickup Cam started doing the exact same thing: Chopping off the first several seconds of the motion event. UPS delivered a package that day (ironically another Ring product) and the recorded video didn’t start until he was walking away, back to his truck. I rebooted the Stickup Cam, and again, this fixed the problem until the next day.

On 1-8 the same problem returned on the Stickup Cam. After almost a year of it working perfectly, I now have the EXACT problem on 2 of my 5 cameras. The only thing that had changed recently was enabling Snapshot Capture.

Finally, that same day on 1-8 I decided to disable Snapshot Capture on all 5 cameras since that was the only recent change, then reboot my Stickup Cam again. The problem has not returned on any of my Ring cameras since disabling Snapshot last week.

As I was having these problems, I was ‘starring’ the events to show Ring support should I call back in again. It wasn’t until I reviewed them on my Windows 10 PC app that I noticed the difference in the recorded video lengths: When my DB Pro or Stickup Cam had the issue, **the recorded video lengths were only 55 to 58 seconds long instead of the aforementioned 1:04 to 1:08 seconds. ** I cross-checked the time lengths recorded as shown in the Windows PC app against the Ring Android app and the times matched perfectly.

In the end, I have no doubt enabling Snapshot Capture, after about 2 or so days caused 2 of my 5 cameras to record shorter videos, therefore missing the beginning of the motion event that caused it to record in the first place. I don’t believe any motion events were missed during this time, they just were not correctly recorded. After months to almost a year of everything working perfect, with nothing having changed on my end, except enabling Snapshot Capture, 2 cameras expereienced the exact problem withinn less than a week after enabling that feature, and continue to work fine after disabling Snapshot. Coincidence?

Snapshot worked fine while I had it enabled, and it’s a cool feature for sure. However, provided my cameras are correctly working, I don’t ever see myself watching time-lapse images to see what happened between recorded motion events. Having my cameras work right is my top priority, which, they do as long as that feature is disabled.

If anyone else has this problem, disable Snapshot Capture and reboot your camera.

@Riley_Ring or @Chelsea_Ring could you please pass along this information to development if you see fit?


Hi @5150Joel. I want to thank you so much for putting in the time and effort to not only do this research and troubleshooting with your device, but then to craft this post and give us this feedback. Neighbors like yourself are what make this Community great and thriving!

I have made sure to pass this information on to the appropriate team for you, and they would like to speak to you further on the matter. I will get you in touch with them, but if you could please first email into us at Once I receive your email I will get you in touch with this team so they can follow up some more with you on this. Hope to hear from you soon!


@Chelsea_Ring wrote:

Hi @5150Joel. I want to thank you so much for putting in the time and effort to not only do this research and troubleshooting with your device, but then to craft this post and give us this feedback. Neighbors like yourself are what make this Community great and thriving!

I have made sure to pass this information on to the appropriate team for you, and they would like to speak to you further on the matter. I will get you in touch with them, but if you could please first email into us at Once I receive your email I will get you in touch with this team so they can follow up some more with you on this. Hope to hear from you soon!

Sure thing, thank you Chelsea. I’ve sent the email as requested.


Is there any update on this?

This will be a really great feature once it doesn’t affect recording length!

@jeremy-wendelken There is no update at this time, as it is something that is still being investigated. I will make sure to update accordingly once this is addressed by our teams. Thank you for your patience!


How about now, Any update? :slight_smile:

@jeremy-wendelken wrote:


How about now, Any update? :slight_smile:

I can tell you I’ve not since heard back from support on the issue after exchanging a few emails shortly after I posted this. I sent several examples of what I described above.

I can also say that problem has not returned in almost 2 months since I disabled Snapshot Capture. Not a single problem like that prior to enabling Snapshot, and no problems after disabling it.

Have you actuallly experienced this problem? I do know a few others posted similiar issues elsewhere after they enabled Snapshot. If you’ve not enabled Snapshot, enable it and see what happens. If within a week or less you experience what I describe above, just disable Snapshot and power-cycle your camera.

So, give it a shot and see if you have any problems. If you don’t, GREAT! If you, it’s an easy fix.

I had the same issue when I enabled snapshot capture, so I currently have it disabled :slight_smile:

1 Like

Ahh ok then. It wasn’t clear you had experienced the problem, or if you were holding off enabling Snapshot in case you had the problem. Well, that sucks then if it’s something you’d actually like to have and use–sorry.

It was a cool feature at first, but after a few days the novelty wore off for me and I found it somewhat daunting combing through pics of really nothing…just time-lapse still images. Then the problems started… Once I figured out it was Snapshot causing it the cost wasn’t worth the ‘benefit’ for me.

All that said, if I was confident it wouldn’t negatively affect my true motion-captured videos, I probably would re-enable it just because…

Hey neighbors! After checking in with my team, they’ve recommended a few more steps to take now that should resolve this concern. If you could, go into your Ring app and re-enable Snapshots (if you would still like this feature), and observe your videos for the next 24 hours.

You should see the preroll still exist and snapshots shouldn’t continue to cut off your videos’ preroll. If you’re still experiencing this concern after testing this, please check your device health page for the device to see your firmware is up to date or not. If it is not up to date, it may still need to wait for the recent firmware that will address this. You can always reach out to our support team to see if they can push this to you. If you see that it’s up to date but your preroll is still missing, please let us know! Hope to hear back from y’all soon. :slight_smile:

For now, I have accepted this post as a solution. While we are aware of this concern and the team continues to investigate, this is a helpful way for other neighbors that come into this thread to try these recommended troubleshooting steps. If these troubleshooting steps do not work, please share in depth information and examples as to what happens so we can pass it along to the appropriate teams. We appreciate your patience and will continue to update this thread with more information. Thank you.

Thanks Chelsea, I’ll bite:

I’ve re-enabled Snapshot on 5 of my 6 cameras–all but my DB Pro only because it’s a bit more of a pain to reboot.

I’ve since uninstalled and reinstalled the Ring app at least once or twice after my original post, so while I’m certain my app is up to date, I’ve not reinstalled it before re-enabling Snapshot for this reason. Firmware for all of my cameras show as ‘Up to Date.’

I’ve set all cameras at a 1 minute interval (the interval option did not yet exist back in Dec/Jan when I initially got the Snapshot update)

Last time it took a few days before the problems started. So far so good after just a few hours. I’ll report back within a week either way.

1 Like

@5150Joel That’s great! Much appreciated for doing that, and totally understandable that it may take a couple days to see if the problem comes back. Please keep me posted. You’ve been very detailed orientated which has helped us isolate the concern, so I appreciate it now and in advance! Fingers crossed for all good things. :slight_smile:

Chelsea when is snapshot available foe gen 3 stick up cam it says 2020

I just wanted to reply and add…

In addition to Chelsea’s reply above on this issue, support also reached out to me regarding my ticket from January. The same person replied to me from back then stating this issue was addressed with a firmware update, and it will no longer chop off the preroll of recorded motion events.

I replied to specifically ask about my DB Pro’s firmware and they again responded confirming I’ve received this firmware on my Pro. I’ve since re-enabled Snapshot on my DB Pro now.

Again, maybe too early to tell but so far so good. I’m liking Snapshot far more than I remember liking Snapshot. It also just seems to work better this time too. More fluent playback of those images when viewed in succession.

1 Like

I’m very happy to report that this issue seems resolved now, at least for myself. Hopefully it’s also resolved for anyone else that experienced the issue.

Last Thurs, March 5th I enabled Snapshot for all cameras except my DB Pro. Friday, the 6th, after support confirmed my DB Pro firmware is up to date (despite showing firmware version 2.2.00097), I re-enabled Snapshot on my DB Pro. Snapshot is set for 1 minute intervals on all cameras.

Hopefully I’m not speaking too soon, but all is well. All recorded motion events are still 1:05 to 1:07 in length, and all play the pre-roll prior to the motion event starting.

When I wrote my original post, it only took about 3 days before the problems started on my DB Pro, and about 6 days on my (wired) Stickup Cam.

I was honestly surprised to get an email out of the blue from Ring, from over 2 months ago to follow-up on the issue. (I thought I was simply reporting the problem, and that was it) Thank you Ring for acknowledging this was a problem, following up with me, and correcting the issue!


@5150Joel This is amazing news! Fingers crossed it stays working as it should. :wink:

We are always around to support our neighbors as best as we can, so I’m glad you were also getting this follow up email from our support team as intended. While some things can take time, I appreciate the patience and diligence in reporting the information to us. It’s neighbors like yourself that help make the Ring Community and the process of getting things addressed easy!

If at any point down the road you see any other concern related to this arise, please let us know. You can also let our support team know via phone, chat or email for a more timely response back. Thank you again. :smiley_cat:

Thank you for all the great help you have offered this and other fellow neighbors @5150Joel. Could you please reach out to the Community Team at We would love to ask you some questions and get your feedback directly as a valued member of the Community. :slight_smile:

1 Like

Ring 2 not wired Ran by battery. It did NOT record a Reckless Driver this Morning that did a hit and run in front of my driveway.!! It had too of been a heavy duty size truck too take out My son’s basketball hoop! The recording Of My Ring 2 was delayed to capture the incident of the trucks description. Made a Police Report .