SmartLock Kwikset 888 Connects but doesn't work


I just installed my alarm today and I have a Kwikset 888 Smart Lock that I was able to pair successfully. Things start failing during setup when it failed to copy my usercode onto the lock. I oped out to skip doing that and the status of the lock on my device list is “Unknown”. At that point, it fails to lock/unlock through the app. I just added the codes manually to the lock, but it’s not connected with my Ring alarm :frowning:


1 Like

Hey @gabosom! It certainly looks like you are using a compatible Works With Ring lock. I recommend removing and reinstalling the Ring app on your mobile device, as well as remove and setup the Kwikset lock, to see if functionality improves.

If that does not resolve this concern, check back here to see if any neighbors with the same lock shared any advice. :slight_smile:

Hi Marley, that didn’t work at all. Now it’s even showing as “Offline” although it has brand new batteries, I can use the codes directly on it, and it connected fine before.


I’m also running into this issue. Did you happen to find a solution?

Im in the same boat. Everything works with the app but the door locks.

Unfortunately, no. I only got that 1 semi-generic reply from the Ring community rep and that’s it. I’m still cannot use the my smart lock with Ring and have tried everything.

I had the same issue moving from Vivint to Ring. Called Ring and they alerted me to the anti-theft setting on your Kwikset lock. The lock needs to be excluded from the old Vivint system. I had the same issue - when the lock is programmed to connect to your Vivint system, it activates the anti-theft feature that is not reset with the factory reset. I had to call Vivint and they walked me through removing the device. and turning the anti-theft setting off. A major pain but the lock now works with my Ring.


I got exactly the same issue.

@mpp414, can you describe the steps you did to turn the anti-theft setting off?

Thank you everyone for your tips.

Yes, thank you so much for the pointer. My lock works now!

I finally had a chance to go back to my old house where I had the Vivint Hub. What I did is removed it from the system completely rather than just turning anti theft off and that did the trick as well. ( @Lopezfam33 it was something like Admin panel - > Devices - > Z-wave - > Remove node)

I noticed that there was an Anti theft option in the admin menu as well but because I had factory reset the lock, this wasn’t going to work for me.