Smart plug schedule does not turn device off

I’ve been having issues with the smart plug since day one. Currently the issue is is that I have the smart plug and it’s in a group and the schedule is from 6 PM to 9 PM to turn on and off. I wake up in the morning and the fountain, that is supposed to turn on and off is still running each morning. I have to turn it off manually. I have deleted the schedules reset them. I have called customer support. I have schedules in both the group and the individual items. Both are from 6 to 9 PM. They are custom schedules. The bridge is echo 4th gen. I did not manually interfere. The bridge did not fail. The internet was never off.

Now the smart plug will not turn on at the correct time. I had to turn it on manually this evening. The scheduled is 6-9pm every day of the week. At 7:30 it had not turned on. No one has access to the account and I was not in it this evening. So now when the schedule does run it doesn’t turn off and now it won’t turn on even when the schedule is supposed to. Please advise

Hi @Tim_notring. Deleting all of the Light Schedules at the device and group level is a good call, to ensure there are no conflicting schedules. I’d also recommend checking the Echo 4th Gen to make sure there are no schedules or routines in place that could impact the schedule from your Ring app. If this concern persists, please follow up with our support team at one of the numbers available here so they can take a closer look. If you are outside of the US, please visit here to see how to contact support.