Smart lights bridge NOT connecting

I feel like this is a massive issue affecting quite a few people and there is no one universal fix. So far I have yet to find one that works for me.

ISP: CenturyLink Gig
Router(s): Technicolor C2100T and Orbi RBR750

Install devices tried
iPhone12Pro Max, iPad Pro

I’ve been on the phone with a higher-level tech for over an hour troubleshooting the failure to connect and have tried these things:

  • iPhone in airplane mode
  • I tried using my iPad
  • bridge pretty much touching my router
  • resetting bridge
  • deleting the app on both iPhone and iPad and restarting the device
  • attempted to connect to my ISP-provided router with ONLY the 2.4ghz radio on
  • manually connecting to bridge vs. using the QR code
  • I’ve checked to make sure that the bridge is not being blocked by my Orbi router(shows up in device list)
  • Use my phone as a hotspot(didn’t connect to this either)
  • register the MAC address in my ISP router(Orbi app doesn’t have this feature)
  • Reset(unplugged) Modem, and Routers

Things I haven’t tried:

  • Hard reset of my Ring Alarm panel(not really interesting in trying this since Ring does not recommend this and it would require me to add ALL of my devices back into it again.

Is there anything that anyone has tired that’s not already on the above list to get their Bridge to connect? This is VERY frustrating.

Hi @KTIZZLE. It certainly sounds like you’ve exhausted all troubleshooting options. I would not factory reset your Ring Alarm Base Station, as this is completely separate from the Ring Bridge and won’t have any bearing on it’s performance. At this point, I would follow up with our support team and see if you qualify for a replacement Ring Bridge. The support agent will be able to see your troubleshooting history and ask a supervisor for authorization to replace the Ring Bridge (if applicable).

Thanks @Tom_Ring I’ll try and call and see if that’s possible. I have little faith that this will actually work but it’s worth a shot I guess.

1 Like


@Tom_Ring I stand corrected. I received my replacement Smart Lighting Bridge yesterday and was able to get it connected on the very first attempt.

For those that are still having issues getting their bridge connected. This is what I used and some of the precautions I took while doing my setup. Hopefully, it helps someone since I have spent many hours troubleshooting w/Ring CS and attempting to install my first bridge.

Setup on:
iPhone 12 Pro Max

Network Router:
Orbi RBR750

Steps taken:

  • Made sure I was using the latest Ring App.
  • Plugged in my Bridge next to my router(previously I had plugged it in closer to the transformer I was trying to connect to towards the front of my house(router closer to the back of my house)).
  • turned Airplane mode on before attempting to connect to my local network within the setup process.
1 Like