Shared Users Invited

I’ve sent a ring doorbell invite to my family and they have accepted this then gone ahead and added an account but they still can’t see our device. What can we do please?

Hi there, @Ellyangel75! It sounds like you’ve done everything correctly here. As long as they’ve accepted your shared user invitation, and are using the same account to sign into their Ring app as they did to accept your invitation, your shared Ring devices should show up for them.

In the shared users’ Ring app, have them check their location drop down menu to see if your location shows up as an option. As the Ring app can control multiple locations, these can be accessed any time from the Ring app main menu or from the top of the Ring app dashboard, by tapping the location option/ name. Once they find your location listed in their Ring app and select it, they will be able to see the devices you’ve shared with them. I hope this helps! :slight_smile:

I spent more than an hour trying to figure out how to complete the invitation my husband sent. What finally worked was this: 1.Using the link in the email I received inviting me to the shared account, I set up my own account and password. 2. From my husband’s account or app, delete the invitation he previously sent. 3. Resend that invitation from his app to the same email address I used to set up my account. 4. Voila, finally, the access code came up and now I’m in! Hope this helps others

The Shared Access invite steps sound straight forward and simple…if it worked. I experienced same issue as in this post but their resolution did not work for me.

I have been using the app on my phone for 6 months without any issues. Today I resent the Shared User invite to my wife (also activated the slider button to share the doorbell device). She already has the Ring app installed on her phone

  • She used the invite to create a personal Ring account and app shows that she is logged in. The app does not list any devices despite accepting my invite. The Dashboard screen on my wife’s Ring app shows “No Location” … click on the drop down does no list any locations.
  • My phone’s Ring app still shows that she has not accepted the invite so we logged he out at her app and logged back in. No change.
  • I deleted her Shared User instance and repeated the whole process…same result

Is my account and setup corrupt in some way? I cannot find anything in community board or Internet that addresses this. This should be a brain dead simple process for any level of user
=== UPDATE ===
Tried the process again and this time was able to get to work with a “send invite again”. There are many steps and having to select “Manage” many times through the back and forth setup communication thread. At this point I assume that we did not click the last of the “Manage” button instances. All the peripheral verbiage speaks of accepting the invite so it is interesting that the button instances are labeled as “Manage” instead of “Accept”. I must have assumed that I had already accepted the invite so no reason to once again click Manage. Too many layers and less than optimal button labeling.

I am finding that this ring alarm system is more of a toy. Soon to go in the trash and get a real system.

But anyway got my wife a new phone and her shared account always worked but now doing the same thing you all report. creates the account but don’t have access to the alarm.

Ring is a joke.

Then when amazon was having issues with there servers guess what made your little ring alarm system useless. This is a toy people.

.

Hi @Johnringis. This Help Center article here will go over the Shared User process as well as outline the roles the Shared User has. Let me know if this aligns with what you are experiencing. If not, try deleting the Shared User, along with any email invitations the Shared User may have, and adding the Shared User again. I hope this helps.