Setting Room Location for Retrofit Kit and Connected Sensors has bugs

I recently installed the Retrofit Kit and noticed while I was programming the app with the rooms where each zone/sensor is located that the following will happen:

  • In the app, go to Devices > Security/Alarm Base Station > Choose a Sensor > Click the “Gear” in upper-right corner
  • Touch “Room” then choose the room in which the sensor is located, for example “Family Room”
  • As I go from sensor to sensor (all connected to the Retrofit Kit) and set the appropriate Room(s), the Room for the Retrofit Kit changes to the last programmed room. If the last room programmed is “Living Room” the location/room for the Retrofit Kit is automatically set to “Living Room”. The setting for the Retrofit Kit changes every time!
  • Then, if I change the room for the Retrofit Kit to “Basement” (where it is), ALL of the sensors attached to that Retrofit Kit will change to Basement!

Is this a bug or an intended feature?

Is anyone else experiencing this?

In either case, can you please get this fixed? I’d like to set the rooms individually without the setting affecting any other senor.

Thank you,

Kevin

4 Likes

yes I have the same problem.

1 Like

Hey neighbors! Thank you for pointing this out to us, and I’ve made sure to pass this onto the appropriate team. In the meanwhile, we have a workout on Ring.com. If you go to Ring.com, log in, and adjust your settings as you would have on the app, it should work out for you! Hope this helps. :smiley_cat:

Hello Chelsea,

Unfortunately, the website has the same results as the app. Changing the Retrofit Kit’s room changes ALL of the sensor’s rooms to the same. Changing an individual sensor’s room, changes the Retrofit Kit’s room to the same.

Kevin

1 Like

@DDT1345 Thanks for letting me know and giving that a try! At this time, if you can reach out to our support team here, they can take a deeper look into this and figure this out with you. Let me know how this goes. :smiley_cat:

Unfortunately, this is still an issue. Will reach out to support but bummed to see this hasn’t been fixed yet.

1 Like

I also have the same issue, what’s the fix here?

Actually, changing on the website fixed the issue for me

Hello,

I just checked the web interface again to see if the problem is solved and it is NOT. Changing the Retrofit Kit location still changes ALL of the sensor locations and vice versa.

Could you double check your configuration?

Kevin

Just set up the retro fit kit and I am also having the issue with the room names. Please fix this bug!!!

The App still has the problem but i was able to set the locations using the website. Once set correctly using the website, i was able to see the correct locations on the App.

I just checked the web interface again to see if the problem is solved and it is NOT. Changing the Retrofit Kit location still changes ALL of the sensor locations associated with that kit and vice versa. I have two retrofit kits in the basement, when I set one of them to “Basement” every associated sensor is also changed to “Basement”.

Could you double check your configuration? Are you sure the web interface worked for you?

I’m also still having this issue.

Wow, this was reported in January and no fix yet? I have 2 ring video devices and am considering getting the ring alarm and retrofit kit but may hold off until bugs are fixed.

Installed the Retrofit kit and I am having the same issue as well. However, I was able to login at ring.com and change the rooms.

Appears assigning rooms on the retrofit kit has been an issue for almost a year. Also the integration with Google Home has been an issue for almost a year. Why have these not been fixed? Seem like Bezos has enough money for one good programmer.

very frustrating that this keep changing all the sensors rooms. even after changing on the website a day or two later they change back to the wrong room and i have to sit and redo all the sensors connected to the retrofit box! Please fix!!!

Still happening in December 2020. Even when assigning Room names via the website (still the only way to set them individually) the Retrofit unit changes to whatever the last device Room was set to. I haven’t noticed the Rooms changing by themselves, but I did experience some changes I thought I might have caused accidentally. I will now pay closer attention to watch for unsolicited.

Another job for that new programmer hire: Fix the website page so that when selecting a device from a list that goes beyond the bottom of the first screen, the right side of the page displays the selected device (not blank space) needing to scroll all the way back up to the top. AND locate the [Save] button where it can be seen without scrolling back down to the bottom of the blank space again. Does anyone actually check these page layouts?!?

1 Like

Still happening in February 2021

Same issue here. Thought I was crazy.