Ring's most recent outage

My ring doorbell stopped working today at roughly 1:30PM (roughly 3 1/2 hours ago). I see that the ring status page says everything is now resolved. Apparently not for all of us…

I have rebooted my android tablet. I have rebooted my router. No dice.

What now ?

  • call customer support ?
  • go out and pull the doorbell, press the orange button for 20 seconds and reinstall ?

This is insane.

Tried ring support phone number…
'Your estimated wait time is > 45 minutes".

Ya know - at one point the first part of November I spent close to 2 hours on the phone with a support person. At the end of the call we both declared defeat and he sent me an email (which I can’t find at the moment) which said he would send out a replacement. Said my credit card would be billed $ 0.01until my return was received etc. I never received a replacement (and my credit card was never billed).

I currently have what is apparently the 2020 version of the ‘original’ ring doorbell. I ONLY want 2.4g support. Of all the variants of the ring doorbell - today - which is the most trouble free ? I would like ring (or amazon) to send me the product they are most proud of (at their expense) to replace the device I currently own. If that is not acceptable I’m afraid I will have to see what recourse I have in returning this device (to Amazon Mexico).

Life is simply too short…

Sorry to hear about this experience, @charlies! As you mentioned, there was a reported incident on our status page, and as of Dec 29, 21:58 UTC this concern has been resolved. If you device was impacted by this, it should now be able to setup and operate as intended. If not, it was a great call to reach out to our support team. As you’ve been handling this with them, the best solution will come from continuing troubleshooting with the team. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

I never did get in contact with the support people. I, yet again, pulled the device off the wall and into the house. Even sitting next to the router the doorbell did not find its configured network. Using the app I tried to ‘switch wifi’ back. No dice. The device could never connect to the Ring 4 SSID (there was a quickly flashing message about ‘authorization failed’ ). Ultimately I removed the device and started from scratch.

But now I have totally disabled motion. The device is now a $200+ USD wireless doorbell (using the resources of its own dedicated router and $25/month ISP). I’ve deleted the apps from my android tablet and installed them onto my android phone. I have disabled wifi on the phone. It may be too early to tell but it feels like the device/phone are happier in the 4G world (than wifi).

Very disappointed.