Ring Video Pro - No response


I bought a Ring Video Pro (EU-model) a week ago.

I installed the supplied transformer and PPK, everything is connected directly to the Ring Video Pro, no old doorbell chime is connected.

It worked fine for 4 hours and then it froze and just showed a white ring.

I restarted the device by holding the orange button for 15-30 seconds, it then restarts and the white ring starts blinking, it blinks for a few minutes and then goes solid white. I am not able to get it in paring mode.

I can press the black button and it makes a sound og blinks blue, but nothing else happens.

What to do?


Hey @cdyngis. Since you have done the reset to no avail, I would recommend reaching out to our support team directly over the phone. Since you are outside of the US, please read our response to COVID-19 here to see how to contact support. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. Feel free to come back and let us know how this goes! :slight_smile:


How did you solve this?

I have the exact same problem, worked for a few hours, then just a white ring. Reset using the side button ends up with a white light again.

I am also in Europe, installed with the supplied transformer, old chime disconnected.

Hi @bjornb,

I actually ended up calling Ring. They where very helpful.

After a quick check of my setup via phone, they concluded that my system was faulty and they sent me a complete replacement unit, brand new.
Just took a couple of days before the replacement unit arrived. ?

1 Like