Ring v2.0 randomly losing wifi connection, time for the bin!

On three occasions now the Ring V2.0 has dropped its wifi connection.
After the first occasion I installed a wifi extender at my front door to make sure the 2G was at maximum strength.
This meant I had to do a complete reset of the Ring and start as if it was a new device.
This worked for about two months, then the same thing happened again. It wouldn’t reconnect at all, so I had to perform a hard reset and start again as if it was a new device.
It has happened a third time now and I am extremely fed up with this device!
What is the point of this Video Doorbell if you have to hard reset it to get it back onto your wifi every few months!!!

It was upgraded with the latest firmware on the last hard reset btw.

Anybody any ideas, or should I just bin this and get a different brand?

I saw your post and it sounds similar to a problem I was having that seems to have been resolved. Here is a copy of my post to the other thread…

Solved!!! Thanks to Tuoni_NL post of Oct '20.

When I purchased my Ring Video Doorbell 3 Plus back in March of 2020 everything worked perfectly for a number of months. I am hardwired into my existing home doorbell circuit for power and to ring my existing house bell. However, over the last few months I have begun losing my internet connection every 2 to 3 days. Nothing changed at home, it’s inexplicable unless there was a firmware update that screwed it up. All I would have to do is pop the battery pack out and slap it right back in (remember that I am hardwired so the battery is always fully charged) and it would re-establish the connection to my router. It kept getting worse until it was literally disconnecting every day.

Frustrated, I started looking for answers. I went to the Ring Help pages first, ugh. Soooooo, based on what I was reading I purchased a wi-fi extender, configured it, hooked up the Ring to it and all was good. Until the next day. Lost connection. Well that was a waste of time and money.

Continuing my search for an answer, I finally stumbled onto this thread and came across the solution posted above from Tuoni_NL on Oct '20. I ditched the wi-fi extender (it didn’t make an iota of difference), assigned a static IP address in my router for the Ring and ta-da, it’s been 7 days now and not a single drop. I honestly am back to loving this thing. Thank you Tuoni_NL, whoever you are. I hope this helps the rest of you.

1 Like