Ring Pro won’t connect to Velop Router

I just upgraded to a new Velop router system. I have my whole home connected, but the Ring Pro will NOT connect. I get the “Cant connect to the internet” error (left blinking light). I’ve tried everything I can think of: Turn off firewalls, open ports, hardwire the router so it’s 3-feet away, separate the 2.4 & 5 signals (2.4 for ring), manually enter network info on Ring app.

No luck! Any ideas would be greatly appreciated.

Hey @RyanV86. Since you mentioned you worked on your firewall settings and ports, have you made sure to establish all the ports and protocols listed here were addressed? Just want to make sure we are covering all our tracks! In addition, does your wifi password have a unique character in it? If it does, I recommend trying to remove this unique character(s) to see if it connects this way. Last thing I would like to know is if you have the ability to create a guest network on your router, and see if it connects to the guest network!