Ring Keypad Firmware Update

I’m trying to update the firmware, and have to update my 2 keypads. The instructions say to unplug the keypad, but mine are using the battery optio (nothing to unplug). They are charged and show more than 50-70% baterry charge level.

Then I press the reset button in back with a pin quickly, a light quickly shows on the keypad, but then nothing…

How doI update the firmware on my Keypads?

Hi @interfx! The best first step for updating would be to charge the Keypad to 100%. Once it is charged, unplug the Keypad and plug it back in. Finally, follow these steps to update your Keypad:

  • Open the Ring app.
  • Open the menu, tap Devices, then tap the Alarm Base Station.
  • On the alarm device list, tap the blue status bar at the bottom of the screen.
  • Then tap any Keypads with device updates available.
  • Tap Schedule Update and follow the directions.

Check out our help center article about updating firmware on the Keypad for more tips. I hope this helps! :slight_smile:

1 Like

I followed your directions exactly.

  1. Full charged my keypad to 100%

  2. keypads are on battery power, so I pressed the button on the back using a pin (quickly). Circle light came on briefly. Nothing else happened…

  3. Still get red alert symbol, sayiong to press the reset button with a pin.

My keypads are battery powered (ie. not plugged into an electrical outlet).

How do I do this?

Sounds like you’ve taken all the proper steps, @interfx. Sorry to hear it is still not updating as intended. Please check your Alarm device health in the Ring app to ensure the firmware version is up to date. If the Keypad is still needing an update, our support team will be happy to assist you with this. :slight_smile:

I have the same issue. I have had notices for firmware updates on my keypads for a while, but it keeps telling me to unplug them. They are not plugged in - they are on internal battery power. So then I press the reset button on the back, and it does not update.

I would like to know the official answer on this one.

Hey @stealthboy. The device needs to be plugged in the whole time to update. Are you able to plug up the device to power, press the reset button on the back and see if the keypad will update then? If not, please be in contact with our support team to have them update this firmware for you. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.