Ring Indoor Camera Stopped Working

I purchased this camera in June 2020 from Amazon, to monitor my toddler while she’s with her grandparents while I’m at work. I initially uninstalled it from my account to install it onto another account. I call myself following the exact instructions like I did the first time, however, once I plug in the device, the blue light comes on, but fails to go into “setup mode” by flashing its blue light. I contacted Amazon since I purchased the device from them, but stated they couldn’t help since the issue happened more than 30 days.

I haven’t been able to use this camera for more than 3 weeks now. And have tried several times to get it to work with no avail.

I’ve tried to troubleshoot the device by holding the “reset” button and plugging it into a different outlet. It’s the same issue.

I need help! Otherwise, this was a waste of $60 and now a bricked camera.

Hey @Isangmahal. Since you have done the reset and it has been to no avail, I recommend reaching out to our support team for a follow up on this concern. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Feel free to come back and let me know how this goes!