Ring Indoor Cam not working

Cameras light flashes on solid blue for 3s then turns off for 30 seconds. I cant get it to reconnect. The power source seems to be working. My wifi’s working great. When I push the top button nothing happens.

Hey @Dadman. Could you try resetting the camera? For the reset, you will press and hold the setup button for 20 seconds, and then give the device a few minutes to reset. After this time has passed, try pressing the setup button again on the top and walking through the steps to reconnect it to wifi through the Device Health section. Let us know how this goes!

I’m having the exact same problem, and tried the reset and it still isn’t working. The camera is 3 days old, is inside and not mistreated in anyway. Help!

Make sure you hold the biputoon down for 20+ seconds for a reset.

I did that already

Having the same issue with Ring indoor cam. It’s not working. Will not connect to wifi. Tried resetting it a number of times, no success. Cam is setup indoors. Cam is less than 4 months old. HELP or send a replacement.