Ring Indoor Cam not connecting to wi-fi during setup

Hi all

I have an indoor cam that is playing up and dropped off my home wi-fi. I have attempted to re-connect it. The app sees the correct wireless network and tries to connect the cam to it but eventually it tells me that there was an issue and the cam light flashes red and blue.

I have tried completely resetting the cam and setting it up from scratch but same result.

I have another indoor cam and thought possibly it was my wi-fi or firewall but I’ve completely reset it and it sets up fine with no issues at all from the same location as the faulty cam.

I think maybe there is something more going on with this cam and it may be faulty.

Anyone come across this issue before? Any ideas for a fix?


Hi @ecstewar. I would recommend trying to try and connect your Indoor Cam to a wifi hotspot to test if your wifi firewall is possibly the issue. If the Indoor Cam connects to your hotspot, you may want to contact your Internet Service Provider to see what settings need adjustment.

If you are still having this concern, feel free to contact our support team for the next best steps. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.