Ring Floodlight Camera (wired) - No Power

So I installed the camera the other day, it worked for a few hours and now has no power - I have taken it down and fed power to it from a standard plug, but there is no power to it, When I power it on I am getting a little flash on the lights, but camera will not power on, or led flash when I press the reset button, or hold it for 15 secs. Video of what happening attached. Any advice on what to do? I bought it a long while ago and have only just installed it.



Hey @IanEagle! Your Floodlight Cam should certainly be powering up as long as it was installed to a junction box supplying the proper power, per the installation guide. As the Floodlight Cam utilizes high voltage, we are unable to advise any wiring or power related troubleshooting. That being said, the standard and best first step would be to ensure no light switch or dimmer switch is interfering with power, and the breaker is not tripped, or off.

For power related concerns, we recommend checking with an electrician.

If this concern persists, feel free to reach out to our support team for a more in-depth look at the Cam. I hope this helps! :slight_smile:

That’s pretty unhelpful. I have of course checked the power supply, all is fine there. I have also wired it direct to a plug, exactly the same issue. The problem is with the device, not the power to it. Please advise.

I have the exact same issue. it seems that the answer the RING has provided is useless. Have you tried other avenues to get an answer? TIA

Returned it for replacement. New one is fine

1 Like