Ring Floodlight Cam - Connection Failed, Audio, and Video Issue

Hi,

I’m fairly new to Ring, and I purchased two Ring Cameras last month (Floodlight Cam and Spotlight Cam Battery), and also recently purchased the Ring Chime Pro V2 to help with the issues that I have been having on these cameras.

I’ve always notice the connection issues once in a while (happens very often actually), and sometimes gives me a black screen when it tries to record motion as well on the cameras.

The sound audio on my Spotlight Cam Battery is much better than on my Floodlight Cam for some reason as well, for example I have the Spotlight Cam Battery mounted further back near my front door, but it picks up street sound and audio much better than my Floodlight Cam that mounted right in the driveway. I’ve also notice a lot of static sound on my Floodlight Cam as well, when I look at recordings and in liveview move as well.

When I’m viewing the liveview sometimes as well, the video is very choppy, lags, and sometimes auto zooms in and back out again.

I hope I am able to find the fix for these issues, since I just subscribed to the Annual Ring Protects Plans an hour ago for both these cameras (since my trial runs out tonight), and I am hesitant to purchase additional Ring products / subscriptions for them as well if these issues aren’t fixed, even after purchasing the Ring Chime Pro. I also have Gigabit Internet as well, so I don’t believe my Wifi would be the issue.

I have already tried a few basic troubleshooting tasks already, such as the following:

  • reseting the cameras

  • moving the Ring Chime Pro around to see if it helps, even though I had already great Signal Strength before already and I don’t think the Chrime Pro made any difference

(RRSI -62 on the Floodlight Cam, RSSI -42 on the Spotlight Cam Battery).

Thanks hope to hear back soon from the community!

It is obvious that the product and application are not up to the expected standards.

I bought the 2- pack spotlight cam no battery a week ago and until now I cannot use it. The video quality is horrible, the 2 way audio does not work, the live feed does not work, only one camera is working. the cameras are 50 cm away from the router and the network speed is 23 mbps , so all the conditions are perfect for smooth operation but still it is not working

I agree, I watched many reviews online and thought that Ring would’ve been a very good solution for my needs, since a few recent events have happened in my neighorhood and felt like it was best to finally invest in an security system. But have been very disappointed withh the product so far, especially having to buy additional products like the Ring Chime Pro, even though I have a very good internet connection already.

Hey there, neighbors! Video and audio connection concerns are often related to wifi, mobile device, or Ring app communication variables. The best first thing to check is your wifi signal strength, or RSSI, which can be found in the Device Health section of your Ring app. Check out our Community post about RSSI for tips on optimizing this signal strength.

If you are using a Chime Pro to extend your network, please ensure the Chime Pro is placed half way between your router and the Cameras, as well as avoiding wifi interferences. The Chime Pro also has an RSSI that can be read in it’s Device Health section of the Ring app.

Removing and reinstalling the Ring app is a quick way to ensure it is up to date and optimally integrated with your mobile device. On your mobile device, try testing audio/video on wifi only, and then on data only, to see if either connection is more efficient. Please also ensure bluetooth is disabled. I hope this helps! :slight_smile: