Ring flood, indoor cams + Mesh network

Good morning. I added an ASUS WiFi 6 mesh router and mesh nodes to our network, replacing our old router and WiFi. When I went to go bring my Ring cameras up on the network, only my Ringo Pro doorbell would join. I could not get either of the indoor stick up cameras to join, nor the Ring flood.

During setup it gets to the point where it asks you to join the specified Ring setup signal, but it won’t allow me to join that network on any of the three devices.

I saw somewhere where it said that Ring devices won’t join a 5G network, so I specified a 2.4 network and it wouldn’t not join.

I did some reading and it said to create a guest network to avoid the firewall issues and I did that, but still wasn’t able to join.

I’m not super tech savvy, but I’ve done all the troubleshooting I can find. Any advice on what I may be doing wrong?

Sorry to hear about this, @Npete78. You’ve certainly covered all the best steps here. Great call on trying out a guest network. You mentioned that at some point, the step for connecting to the Ring Setup access point is unable to do so on any Cameras. This is quite odd, especially if these Cameras operated just fine prior to the network change.

If you have another mobile device available, try performing the setup on a different mobile device entirely. Please also ensure there is not a vpn enabled. If these Cameras still do not succeed at the step of joining the Ring Setup network, please hold the Camera setup button for 20 seconds to perform a reset, and try the setup again. Feel free to let us know how this goes! :slight_smile:

When you tried forcing it onto 2.4ghz did you actually split the network into 2 networks one for 5ghz and one for 2.4ghz. If not give that a go.

1 Like