Ring Elite does not connect at 1Gbps

I received a brand new Ring Elite (the second one I try), firmware updated and hardwired with CAT6 to my UniFi switch (PoE - 24/250W) and it only connects at 100Mbps never at 1Gbps. The Ring app shows what appears to be an error: “Signal Strength: RSSI-256 (?)” and I have tried different cat6 cables, different ports but still no go.

The Elite supposedly supports 10/100/1000 connection speeds but this is not the case with the two that I’ve tried. Is this a bug? is there a special setting that will allow it to connect at 1Gbps?

I called support twice and they run their usual “test the device” routine and said everything looks good with the doorbell but couldn’t figure out why it wasn’t connecting at the desired speed.

Is there anyway to get an escalation support engineer to look into this? I’d prefer not to go through the same support call experience for them to tell me everything is fine.

Is anybody at Ring monitoring these threads?

Can anybody confirm if the Ring Elite only supports 10/100Mbps?

I might have to return this one as well

Good question @Lucho! The PoE adapter that comes with your Stick Up Cam Elite, is rated for an Ethernet speed of 10/100Mbps. I hope this helps! :slight_smile:

1 Like

Thanks Marley, I appreciate the reply but I’m plugged directly to my UniFi switch provides PoE (not using the PoE adapter)

If the PoE Adapter is 10/100Mbps, is it safe to assume the Ring Elite is also 10/100Mbps? I just want to make sure there’s nothing defective which prevents it from connecting at 1Gbps.

It seems odd though that a so called “Elite” device can’t take advantage of the faster connection speed specially for video transport.

Can anybody from Ring confirm the Elite doorbell is only 10/100Mbps?

Hey @Lucho! Thank you for your continue patience with this inquiry. After further confirmation, the PoE adapter does indeed support 10/100/1000 speeds for the Video Doorbell Elite. If you are seeing less resources being utilized than expected, do keep in mind your router may only delegate the resources as needed. I hope this helps! :slight_smile:

Thanks for the info Marley, I appreciate the reply.

My switch is UniFi 24/250W and all other devices which support 1Gbps are connecting at GigE speed. Only 8 ports are being used right now so this has nothing to do with low resources on the switch. I’m using a very short patch cable to test this and this is the second Ring Elite that has this issue.

Perhaps, my vendor has a batch of defective devices? I mean get have to return this device as well.

I haven’t had to make any changes to the switch for other devices to work but are there specific port settings the Ring is looking for?

Hi @Lucho - try giving our support team a call at 800-656-1918 to take a further look into this!

Thanks @Jennifer_Ring!

As an update to the entire community, I called Ring Support and Amy did a great job helping me with this. What I didn’t know is that 1Gbps is required in order to have HDR support on the Ring Elite Camera and she concluded that my device might be defective. She’s sending me a new one.

As a side note, this is the second Ring Elite I bought from Amazon and they both exhibited the same issue. I’ve heard rumors that some Amazon stores are shipping refurbished devices so watch out and test your devices to make sure they work 100%.

Happy New Year!

1 Like

Hi there, I have the same setup, UniFi Switch, etc and having the same issues. Did a new device fix the connection issues? Thank You!

@jgqdallas, I’m still waiting for the new unit to show up, I’ll follow up once I install the new one.

1 Like

@jgqdallas, I just received and tested the new Ring Elite device they sent me and unfortunately it still doesn’t connect at 1Gbps. It only connects at 100 Mbps FDX.

This is the 3rd device I try so I think this means the “Elite” can only connect at the lower speed which would be very dissapointing for a $500.00 device. Either that or this could mean that there is some kind of incompatibility problem between the Ring and the Unifi switch.

Can anybody please confirm with certainty that this can connect at 1Gbps with other switches? and can you please confirm if that allows you to enable the HDR feature enable on the Ring Elite?

1 Like

I’m having the same issue. My ring elite only connects at 100m using a ubiquiti Poe switch. Has there been a resolution?

@Lucho, sorry to hear the new device still is not connecting at 1gb. I haven’t had any luck talking with tech support as they tell me a connection of 100mbps is good enough and will not do anything more. If anyone else has better success please share. Thanks!

Unfortunately, Ring Support is unable or unwilling to help get the official answer but I have tried with multiple switches and can confirm that the “Elite” does NOT support 1 Gbps. This is not documented anywhere by Ring and their support team refuses to escalate to (or doesn’t have) 3rd level Engineering support to confirm this.

@JGQDALLAS wrote:
@Lucho, sorry to hear the new device still is not connecting at 1gb. I haven’t had any luck talking with tech support as they tell me a connection of 100mbps is good enough and will not do anything more. If anyone else has better success please share. Thanks!

@JGQDALLAS, Same here Ring Support has been useless getting answers and have had me going in circles. First they said the HDR required 1Gbps but have not been able to help resolve the connectivity issue. I tried with different Ubiquiti switches and also with NetGear switches and have determined on my own that the “Elite” DOES NOT SUPPORT 1Gbps link speed.

RSSI reports wireless signal strength, but your question is about wired Ethernet, so RSSI doesn’t apply to your need.