Ring Doorbell video using Spectrum WIFI

My first generation ring Doorbell worked ok using a AT&T DSL system. It worked but was slow at 3mbs. I just upgraded to Spectrum 200mbs Service and my Doorbell will not show live video or motion alert videos. I do get the motion and Doorbell sound alerts. The camera works because I see the snap shot picture on the dashboard section. Just no video.
Is it possible the Spectrum modem/router is blocking the video?
Spectrum router: 802.11ac Wave 2 Router Model Number RAC2V1K.
2G WIFI with WPA2 encryption.
I just need help figuring out what ring needs to show live and recorded video and audio. AT&T worked and Spectrum doesn’t. You can see in the attached picture the WIFI name is in red.
Thanx
Joe

This issue could well be due to the Firewall on the Spectrum Router dependent on how you change the setting to allow minimal or custom security for the Setup process you may be successful.

Thank you very much for your help.
I’m not sure what part of the firewall. See attached.
Notice the RED network name above.
Is this the area I need to change?
Thanks
Joe

I had an issue that seemed similar. It was a firewall problem where some ports were blocked for peer-to-peer apps. It seemed like you were in the right place in the first picture where you were in your router firewall settings. I have a Spectrum router as well but mine is different from yours.

1 Like

Thanks much for your reply.
I turned off the ipv4 and ipv6 firewall and reprogrammed the ring doorbell. I have the same problem. Any ideas on how to unblock the ports? Also the wifi name In Device health went from red to gray now.
I’m not sure what the deal is. I do appreciate you help. Thanks
Joe