Ring Doorbell video stopped working

My ring doorbell video recordings show the first frame of video then only audio for the rest of the clip. When attempting to switch to Live View it sits on “activating device” until it eventually times out. Device Health Report shows a clean bill of health. Signal strength is RSSI -44, which it has always been. The last successfully recorded clip was on 9/3/2020.

Hi @mr_zedly! The best first step here will be to ensure your Doorbell battery is fully charged. Next please attempt a new setup within the Ring app to get this Ring device connected to your network.

If the device will not complete a setup or operate as intended during setup, please reset your device by holding the setup button for 20 seconds. I hope this helps! :slight_smile:

Hi Marley,

The doorbell is always powered. I have reset the device and added it back into the app but the problems persist. If I try to activate Live View it tries to connect without displaying anything, then reports “Live View Ended”. At the moment the doorbell is sitting on my desk less than 2m from the wireless access point, so it’s not a connectivity issue.


Same problem here. I’ve done multiple resets and setups. The app is the latest version. The problem is not my internet. The Ring is fully charged. Setup is easy, wifi connects easy, but live view does not connect. The motion sensor does work because it sends me alerts. I’m stuck.

Wondering if you found a fix for this… our 2 week old Doorbell 3 worked fine for the first 5 days then has been unable to connect 80% of the time. RSSI ranges from -40 to -59, it’s 25 ft from the router, gave in and bought a Chime Pro which is on the interior side of the wall that the doorbell is on (showing RSSI -39), the doorbell shows battery is fully charged and is hardwired properly. Really regretting going with ring.

hi @holhartz, I didn’t find a fix. Our 4 year old Ring (original) appears to have ceased to function as intended. I tried repeated resets but it won’t record video other than the first couple of frames, after which the video is black, but the audio continues. It also wont respond to a request for a “live” view from the app. Its WiFi connection is just fine and hasn’t changed. Conclusion? “It’s dead Jim”.

1 Like

I seem to have a similar problem. The Ring Doorbell seems completely functional, on the Chime Pro network with good signal, doorbell works, health is good, motion events are recorded, but the video does not connect. Events are recorded but do not play back. I just lost one of the spotlight cameras as well. These seem to have a limited lifetime.

Sorry to hear about this, @JJCharfman! If you’ve tried the suggestions previously mentioned in this thread, our support team will be happy to provide more in-depth assistance in this matter.

Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.