Ring Doorbell Pro will not factory reset

Last week my Ring Doorbell Pro stopped working and nothing had changed at my house, so I tried to reset it by pressing the button on the side for 30 seconds but it goes back to the same error each time. The blue light is on at the top flashing and then goes to solid blue, and repeats.

So I tried to delete the device and restart the installation. I rebooted my router (had teh same password), and then proceeded to reset the device by pressing button for 30+ seconds. When I step through the setup and scan the QR code, it does nothing… I cannot find teh wifi for the device either… does that mean the Ring Doorbell Pro wifi mechanism is broken? I have only had the device for about 6 months.

Sorry to hear about this experience @sj_usa! I recommend uninstalling and reinstalling the app, then trying another setup. If the device continues to fail at this connection step, this would be best brought up to our support team at 800-656-1918, for more in depth troubleshooting.