Ring doorbell pro will not connect to google wifi

I just changed my wifi router to Google wifi and my Ring doorbell pro will not connect to my wifi. I tried to reset by pushing the small button for 15 seconds. I tried to cut the power to hard restart it I put my wifi router two meters from the doorbell but it still will not connect.

In the app the doorbell finds my wifi network and it shows a strong signal (see picture). I enter my correct password for the wifi and the app ask my to wait by saying “Rome wasn`t built in a day” and then after maybee 20 seconds the voice tells my the doorbell can not connect. I tried at least ten times and the same thing keeps happeening. The app tells my that I need to get a stronger signal but the router gives it a strong signal. I also tried to shut down two of my google wifi routers (I have 3 all together in my house) so the Doorbell could contect to my main google wifi router, this did not help. I also talked to customer service for 45 minutes and they told my it not Ring Doorbell that is the problem but my wifi. But thay also say that ring Doorbell pro is compatible with google wifi.

I installed my old wifi router and the ring doorbell pro can connect to it. But I used a lot of money on my new google wifi and I want to use it…

any one else using google wifi with Ring doorbell pro??

what more to do??


I looked some more into it and it seems like google wifi automatically switches between 5 and 2,4hz network. I have been told there is not possible to turn this of in the google wifi system configuration.

Is Ring doorbell pro only abel to connect to 2,4hz nettworks?

Can this be the reason I can not connect the doorbell to my google wifi?

If yes, why is Ring claiming the doorbell to be compatible to google wifi?

I solved it by calling google. My network name had a special character. So by simply changing the name and removing a small character (’) from the name Ring Doorbell pro was able to connect to my google wifi.

Easy but I used four hours, including a long distance phone call from Norway to U.S for almost one hours, to solve it…


Thank you so much for sharing this with the Community @GunhildNorway! These steps will certainly come in handy to other neighbors. Glad to see you were able to resolve this! :slight_smile:

Got the same problem need to know the answer too?

I can confirm this also worked for me.

1 Like

I was ready to send my ring back. It would connect to a personal hotspot, but not my Google Wifi. I read this post and renamed my guest network as it contained a special character. Worked immediatley. They should include this tidbit in the instructions with the doorbell.

Can you please suggest which names for google wifi are valid

Thank you for this!! Solution worked for my stick on camera. I notified the Ring as well since I spent several hours on the phone troubleshooting.

1 Like

I also have Google WiFi network and having issues. My network name does not contain a special character, so curious for other fixes?! Thanks.