Ring Doorbell Pro suddenly stopped working

Suddenly after 2 or 3 years Ring Pro stopped working. Can’t connect to wifi, voltage is at 4091mV which is higher than my Ring Pro in the rear of the house. Pressed reset button and no white spinning wheel. Tried hard reset and nothing. Anyone have any ideas other than it is dead. Pretty disappointing having spent all that money if it has died. Thank you

Hey there delp241 I’ll be happy to help you troubleshoot your Ring Video Doorbell Pro!

Let me ask you this, have you tried performing a 10 minute power cycle by turning off the breaker that’s associated with your doorbell?

The power cycle has worked wonders for a few of my buddies and I believe it’ll work for you to!

Try chatting with Ring support, they might replace your Ring device.

Same issue. Any way to diagnose device as it only has two screws on the back. No usb port.

Same issue in the above message with 2-3 year old ring doorbell pro suddenly stopped working. Device is installed in sheltered location, mild climate. Measured the voltage to the ring device as 19v (16v min required, same as original install). Did trouble shooting with ring support but device not functioning. Ring now wants me to do a return but I learned that they will not replace or repair it. They will provide a 35% discount on a new device purchased from them. Not a real RMA. I am trying to analyze paying $250 for a doorbell product that easily fails in 2-3 years which only has a one year warranty? Not aware of the overall failure rate of their products? Any advice on other options? Is there another source for repair? Are the doorbell products any different than the devices they have been selling in the last 3-4 years? Still paying the same price for the same thing for the same warranty? Trying to make sense of this??

If anyone has the protect plus plan your devices are warrantied as long as you have that plan. Just in case someone didn’t know this…

I have the basic plan but no warranty coverage.

My Ring Video Pro recently quit working at about 2 1/2 years. Mine has a USB port behind a little tab on the oppisite side from the reset button. Is there anyway to diagnose the failure? Are there repair shops?

Having this same issue. Ring was working great for a few years, not it’s not. i even replaced my transformer to to make sure it wasn’t the problem. i would wonder if this might be related to a possible bug introduced in a firmware update. Seems a little too widespread, and happening around a timeframe. i am speculating, but the theory is sound.