Ring doorbell pro not working anymore

Hi there,

My Ring Doorbell Pro was working for a good year, however it suddenly stopped working at some point (about a month ago). I tried a hard reset to reconfigure.

And the bell goes into setup mode (white light spinning fast), however, the setup is unable to succeed, the Ring wifi network that was suppose to show up is not anywhere to be found.

Tried with 2 different phones and a tablet (all android), tried to find the wifi using a windows and a mac laptop. And none of them are able to detect it. Did a number of hard resets on the device, but it’s always the same story.

I have tried contacting the support number (00 800 87 00 97 81) as I live in Ireland, but I can’t get past the language selection menu (line hangs up as if I hadn’t press the number (tried with 1 and 2 for english and spanish as I am proficient in both).

I bought this on amazon, so asked them what I could do about it since I have 2 years of warranty. They asked me to do a reasonable attempt to contact you via email. There seems to be no email that I can try. This seems to be the only option I have, as the chat is not available for issues. Is there a way to contact you to get this looked into?

Edited to say, I am paying the Basic protection plan which extends the warranty to 2 years.

Best regards,

Adrian T.

Hi there, @AdrianT. When reaching out to our support team by phone, please ensure it is between the hours of 8AM - 8PM CEST. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Feel free to let us know how this goes! :slight_smile: