Ring doorbell not charging

So not happy with my Ring products. Firstly, my chime pro stops working and no solution I can find will fix it.

Now, my hardwired doorbell, which has been hardwired and showing battery strength of 90-100% for 6 months is showing low battery and not wired to the mains in the app! Nobody has touched it! What’s is happening? Any suggestions???

Hey there, @LisaH. With both the Chime Pro being offline and the power from wiring not providing power to your Doorbell, please ensure there is not a breaker flipped that might control power to these areas. Charging your Video Doorbell to 100% and checking the wiring connection on the back can help with the wired charge being detected.

Depending on the status of the Chime Pro, usually trying another outlet in the home or resetting the Chime Pro can help resolve a concern. To reset the Chime Pro, please hold the setup button for 15 seconds, then perform a new setup of it. If this does not resolve your concerns, please read our response to COVID-19 here to see how to contact support. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times.

Hi. I’ve just tried all of the above. With regards to the ring doorbell, I’ve removed it and charged it overnight. I’ve checked the wiring and all is ok, even as I was unscrewing and screwing the golf screws which the two wires connect to on the backplate, the original doorbell box was ringing so this shows the wires are still live. However, when I fix the doorbell on and tighten the screws and press the ring doorbell button, it rings on the device but no blue light on the push button as there usually is when it’s connected to the mains and the inside bell box doesn’t ring, how can this be when the wires are clearly live and it was ringing as I touched the gold screws on the backplate?

Also, I have tried absolutely everything listed in your answer and on the ring forum etc to make the chime pro work, again, this was working one day and not the next. This stopped working about 4 weeks ago, I’ve just been too busy with work to look at them both. Not happy at all