Ring Doorbell no longer displays LIVE view

i missed a very important delivery: Ring did not ring and Alexa did not sing. i spent 5 hours today trying to figure out what went wrong. i found your reply and my Live View is working properly although my battery on Ring 1st Gen is showing 00%<br>i want to say thank you to djo??1 who gave the walk thru solution which appears to be software related. I would They ruined a perfectly good day. There is just so much rubbish on Ring.com
i have been blocked using what words i expressed

Hi, just to add to this . . .
Installed a Doorbell 3 a few days ago and everything seems fine with the exception of Live View, and ‘view on activation’ on phones or Echo Show which is not performing - or very intermittently.
I’ve tried a ll the reset processes described in a previous post - to no avail.
I’ve investigated wifi strength which was around -55 / -60 (being outside), so I’ve added a dedicated powerline wifi extender with a dedicated channel and dedicated SSID which got the RSSI to - 38 (clean), which is pretty darned good. This is despite already having a mesh network covering the whole house and performing very well across other devices.
Speed Tests show 33Mb down and 20Mb up at the bell location.
I’ve opened all the suggested ports to the IP of my camera (I know its DHCP but I’ve set its current lease to months) to see if this helps (it appears to make no difference).
Doorbell activates and notifies both 4G phones and WiFi network devices at my location with the alert sound, motion detection does the same, but neither reliably activate the video feed on my Echo Show device.
Live View ‘VERY’ occasionally works if I repeatedly either tap on the Live View screen on my mobile device, or repeatedly ask Alexa to “Show Front Door”, but it’s as good as useless as a reliable method of monitoring, or to “Show” me who is there or what is happening during an ‘event’.

Of note here, once the feed is activated, the video quality is excellent - so again doesn’t point to my network or bandwidth availability.

I don’t see a Chime Pro being of any advantage, as my own extender has covered off the private / dedicated network connection to the Doorbell 3.
This is very dissappointing, and after everything I’ve tried here I’m not convinced the issue lies in my network. Come on Ring - this isn’t an isolated issue, what’s going on ?
It would be useful to understand more clearly what the route of the video traffic is in this configuration as if it is as I suspect_ _via Ring is there a potential bottleneck here that needs addressing?
Any assistance or next steps (if there are any left) from the support team would be appreciated - after all, myself and clearly MANY other people seem to be having this issue., so is it really US ??

1 Like

I get motion alerts but everytime I try to open live view to see what’s going on, it fails to connect. Live view only works when it doesn’t follow an alert or if I open it after sometime has passed following the alert. It makes the alert useless if I can’t view what’s going on in real time. I started having issues once the free Ring Protect Trial expired. Everything worked fine before. I think it’s Ring’s ploy to get me to sign up.

Lets all return our Ring doorbells… i have 2 ring doorbell 3 and still got 2 weeks to paly with it. Both intermittently wont show live stream. I have wasted lots of hours following every possible suggestions . I cant wait Ring to fix the bug…these will go back …enough of this.

There is no doubt it is a firmware issue. I have tried all methods, including changing the router, and none has worked so far (mine is Ring Doorbell 3 Plus). “Live View” only works one out of ten times.

As a side note, the below post seems make sense. I think for some reason, the doorbell switches to “sleep mode” after some time to conserve power, and it affects “Live View” operation.

https://community.ring.com/t5/Video-Doorbells/No-Live-View-Give-it-a-try-SOLUTION/td-p/44568

If this issue is not resolved within a week, I will return mine!

Also, here is the issue I have experienced with “Live View” (I recorded the videos with Screen Recorder when using WiFi and LTE):

https://www.dropbox.com/s/eyi170opafuvhq7/Ring_LiveView_WiFi.mp4?dl=0

https://www.dropbox.com/s/bvfjs5xqtdkepg3/Ring_LiveView_LTE.mp4?dl=0

Note that, sometimes, “Live View” indeed works, especially right after a motion alert. There is also no issue with motion alert/detection, and video recording, and Alexa annoucement.

I have a Ring Doorbell 3 Plus and have discovered that the doorbell goes into some form of power save mode which means it disconnects itself from the wireless. I can tell this because it is no longer a connected device on my sky router. If you try and connect for live view this fails because it’s not connected however when someone walks past or presses the button it wakes up and reconnects (it is then listed as a connected device) I have discovered when it detects motion or the doorbell is pressed the live view works for about a minute then stops again. I suspect Ring have done some code to help battery life but got it all wrong. I have an RSSI -50 and all the tests recommended by Ring pass fine. I suspect in a future firmware upgrade they will realise their mistake and fix it even if they don’t admit it.

I have had the same problem. It did work. But stopped. They gave me the same instructions.

Returning is not an option in that it’s too late. They won’t accept it. As that is the case, is everyone sticking with Ring or going to something else? I am disinclined to stick with a company that leaves your laundry in the wind and makes NO effort to help.

1 Like

Fixed it! My WiFi broadcast the same SSID and password for both 2.4 GHz and 5Ghz. So I changed the SSID of the 5Ghz and got my Doorbell 3 Plus to connect to this. I think it was trying to connect to both 2.4 and 5 at once. Now it can only connect to one bobs your uncle :slight_smile: Still not convinced it’s not the doorbell problem as I have no other devices that have a problem. Anyway it’s fixed for now at least.

2 Likes

My Ring doorbell 3 was on Wi-Fi 2.4 GHz have just switched to 5.0 GHz (different SSID). Tested and LIVE view worked. Fingers crossed it will continue to work. Thank you so much for the suggestion. Surprisingly my RSSI has fallen from 60 to 51.

I did not time pre above switch but now on 5 GHz to get Live view on Pixel 2 XL:

  1. Ring app about 12 seconds

  2. Rapid Ring app about 7 seconds

Rapid Ring app would be even better if individual widgets were added for doorbells.

I have the same problem. Seldom does this thing connect to live view. I have upgraded my router, switched to faster internet service, moved the router to within 6 feet, jumped up and down while rubbing my stomach and patting my head, and still nothing. Kind of defeats the purpose of having a remote door bell when I can’t even access the thing when I am home let alone away. Useless. I have other security cameras from Arlo and never have an issue connecting to them from anywhere. I wonder if they make an video doorbell cause this thing just plainly sucks!

5 Ghz does not work for me. In fact, I have set up an UAP-AC-Pro Access Point and have only my Doorbell 3 plus connected to it. I have tried 2 GHz only, 5 Ghz only, or both, but do not see any improvement. WiFi signal has always been great, but “Live View” just works intermittently.

The Chime Pro that I ordered will arrive soon, and I will see if it makes any difference.

I have just instslled the pro3 device and i a have full functionality except live view only works 10% of the time. I have not been able to get it to work when away from home at all. I have completed all of the fixes listed above. When i change from 2 to 5 ghz ans vice versa it eorks for approx 5 views and then reverst to same issue…

I have the same experience works for a day or two then reverts. This morning the RSSI had increased from 52 (yesterday) to 79 which made speaking to the delivery person almost impossible. Rebooted the node (Synology MR2200ac) doorbell was connected to and RSSI went back to 52. I will put this node on a smart plug and reboot every night to see if this helps.

Some updates: The retailer that I bought the original Ring Doorbell 3 Plus sent me a replacement and allowed me to keep the orignal one for a few more weeks for testing. With the two doorbells side-by-side connected to a dedicated Unifi Access Point, the replacement has been working well, with no issue so far (under various network configurations).

I also received the Chime Pro yesterday, and decided to connect both doorbells to the Chime Pro for testing. Interestingly, Live View is working well with both doorbells under this setup.

But I guess it might be too early to say something definitely right now, and I will continue to test them in the next few days.

Does anyone know if this issue has been fixed by Ring yet? There is still no live view available 6 months later. Live view works on LTE but not on home network, network config has not changed and the doorbell has worked fine for 4 years prior to May 2020. Everything points to a firmware update that has caused issues with IOS. Any commnent Ring ? When will this issue be fixed ?

I have the same issue. no live view. If I ring the doorbell, it give me live view for one time… then back to “Your phone is haviong trouble connecting to your ring doorbell”. This is extremely frustrating. especially considering its the christmas season and there will be a lot of deliveries! I have a ring Doorbell 2 pro. Full power. RSSI -50 did a full reset and it worked once… then nothing. Getting rid of it!

1 Like

My ring pro stopped displaying live view since a few days. All signals are perfet, rebooted everything,no live view on my MacAir and both Amazon displays. Live views work on my Iphone. Please fix this !

The amount of babysitting this product requires is absurd! ! I have run through the mountain of troubleshooting suggestions multiple times with only occasional but reliably temporary success, then back to square one. Not a chance of buying another Ring product - it shouldn’t be a part time job to keep it working - especially when the product is intended to enhance home security. If anyone has had better luck with a different brand, please share! Enough is enough.

1 Like

Does anyone from RING actually read these threads?
I can’t help but notice there are no answers or bug fixes in the pipeline being announced or responded to in this forum.
I posted these problems quite a long time ago, and have seen many, many more people suffering the same issues. I’m technically ‘savvy’ so am totoally convinced that there is noting more I can do here to improve the situation and that it lies firmly and squarely with Ring as a problem with either their software or infrastructure.
I have a £20 security camera built on the Raspberry Pi platform that, although not as high tech or slick looking, does 'very little less ’ than the Ring 3 doorbell ‘in it’s current condition’.
I had intended to purchase this as my first Ring device and potentially expand into additional cameras, indoor and out, and possibly an alarm system too; after this pantomime I’m wondering whether to bother recharging the Ring doorbell battery if /when it goes flat for the benefits it’s bringing me over a basic doorbell !!
Dissappointing Ring - such great potential - such poor exectution.

1 Like