Ring Doorbell 3 is NOT compatible with TP-link deco M9 plus mesh

Got a brand new Ring Doorbell 3 recently and tried to install it. Turned out it kept dropping internet connection. I have a Deco node in 3 ft away from this doorbell, still could not make the connection. I saw people’s complainings everywhere on this board afterwards. Have tried every possible changes on my mesh side, not working. Called Ring tech support multiple times but not helpful. Decided to return it tomorrow.

Not a good experience at all.

I have the similar issue, bought the ring doorbell 3 and tried connecting it with TP-link deco M9 plus mesh. I am able to hear the sound and see the vidoe throgh my ring app but my ring app is not able to communicate with the doorbell, I verified ring app has the microphone access but no luck make it work.

I tried calling customer care and they said there is some ip blockage issue and I need to work with network engineer to fix this and that is only available to premium customers and I can enroll in it by paying $150, It did not make any sense to me so i said i need to check online and found bunch of tp link deco and ring compatiblilty issue, very frustrating experience

From what I can tell Ring Doorbells have issues with TP Link Mesh networks. I have a replacement Doorbell on the way but I don’t think it will solve the problem. I have set my Deco M5 network to send notifications when my Ring Doorbell connects and disconnects. On average it connects and disconnects every 2-3 minutes. Sometime multiples times with in a minute. I have tried a guest network set to only 2.4Ghz with beamforming on/off and fast roaming on/off and Mesh on/off on the device only.

I have since created a new wifi network with an old TP Link router and the connection seems to be stable. My conclusion is Ring + TP Link Mesh = FAIL

Does anyone know if there is the same problem with the Stick up cams and the M5 deco. Recently bought the M5 to try to sort my wifi issues with the stick up cam. It started ok a couple of weeks ago now it’s showing off line in the Deco setup and it isn’t giving me notifications.

Just happened to me too M9 Plus, Ring 3 Plus disconnecting constantly