Ring doorbell 2 won't connect to Netgear nighthawk

Can get my ring 2 doorbell to connect to my netgear nighthawk ac2300 router. Any one have a similar issue?

Make sure you’re connection is to the 2.4 GHz SSID.

It is I have it on my guest connection which is 2.4g

If you have another phone, try using it. Sometimes certain phones have issues. My LG G8 won’t work well but my Pixel 3A works great connecting Ring devices.

I got it to work. I pulled the battery from the doorbell and restarted and it connected no problem. Thanks for the help!

Glad to here it works!

Hi,

I just thought I’d share my experience with other users who seem to be having similar issues.

I’ve had a Ring Doorbell 2 with seperate chime for a little over 8 months, had the Nighthawk R8000 about six months! All was fine, had no issues connecting everything initially. About 2-3 weeks my Ring Doorbell started taking longer to connect and often dropped off the network so on Sunday I decided to start troubleshooting…I tried everything that I could think of.

Changed SSID

Changed Security password

Tried connecting to guest netork

Even tried connecting with no security…NOTHING WORKED!

So I called Ring Tech Support, we managed to get the Doorbell to connect to my phone’s hotspot straightaway (using my iPad to setup the App) so that ruled out the doorbell being faulty. After a lengthy phone call they decided to send me a Chime Pro (FOC I will add) which acts as a bridge, That arrived today and connected to my network straight away, no issues. Tried to connect the doorbell directly to the Chime Pro but still wouldn’t connect, reporting that my wi-fi password was incorrect!!! At this point i’m fuming!!

Anyway I found the solution which isn’t ideal but worked

Create a DMZ IP address in the router, go through the setup process in the Ring App and assign the IP address manually to match the DMZ that was created and sure enough it connected first time…

The bonus I suppose is I got a Chime Pro for free. Hope this helps others.

Cheers

1 Like