Ring doorbell 2 won’t reset

Recently my doorbell stopped working the way it should at night time. The night vision video had a lot of interference and wasn’t easily viewable.

I figured it was worth giving the doorbell a reset to see if it helped at all and for a short while it did. However I then notice a few weeks later I was no longer getting any motion alerts from the doorbell and when I went to check I was no longer able to view video at night at all, it was just a black screen no display at all.

This wasn’t great but at least the doorbell still alerted me when someone rang the doorbell.

I tried another reset to see if it would make any difference and now I am stuck. I did the usual and held the reset button for 15 seconds, it appeared to be going through the usual reset steps but never finished. Now it is stuck mid reset. It won’t finish resetting, it won’t go into setup mode it won’t do anything at all.

The light just flashes blue endlessly and I’m unable to set it up or add it back to the app.

The flashing is 3 slow flashes, followed by one fast flash. I searched online but couldn’t find anything to say what this meant

Is there a way to get it to come back to life or if it kaput?

Hi @Kj82 . It seems like you’ve tried a lot of the basic troubleshooting steps already to no avail. In that case, I would recommend reaching out to our support team so they can look into this further. You can give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile: