Ring Doorbell 2 Spinning Light ERROR

Doorbell won’t light up to set up, I’ve tried the hard reset and there is still no spinning light or anything tried getting a new battery, charged it completely and still won’t work.

Hi there, @ak5! When a device seems unresponsive or receiving no power, the best next step will be to check the battery connection. Please ensure the battery is inserted correctly and all the way in the slot. If you have a non-removal battery, charging it for several hours should have worked. Try resetting the Video Doorbell by holding the setup button for 20 seconds. Once complete, you should be able to complete a setup in the Ring app.

If there is still not a response from your device, or it will not setup, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.