Ring Doorbell 2 not using hardwired

I finally got around to hardwire my Ring Doorbell 2. So I bought a transformer that is 12-24V AC.

I wired the doorbell and the app showed “hardwired”. That worked for a few days, then I got a battery low warning and I see the battery is back on “battery”. I measured the wires and the doorbell (measured on the screws on the back) is getting about 25V.

Anyone have Ideas why it stopped using the hardwire? anyone else had this happen?

Hey @brynjarsj. Since it was previously hardwired and no longer is, I recommend following up with our support team on this concern. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.


Yes the doorbell decided all of a sudden to go only battery mode even if it has current measured all the way to the screws on the back. Was hardwired and working that way.

Is there a way to create a ticket to get a technician to tell me what he thinks? The doorbell is online on battery registered to this account so you should be able to check it remotly.

I just dont feel calling tech support.

@brynjarsj As we are a neighbor to neighbor support forum, we are not a direct line to support and I’m unable to assist with creating a ticket for you. You will need to call into our support team in order to get this addressed. Feel free to come back and let us know how it goes, as your answer may help other neighbors!

I wish you luck, Ring Support are nice to you face but a complete waste of time. I spent 1hr and 40 minutes on the phone with “Ty”. Nicest guy but did NOTHING! Just kept asking questions over and over and over…the SAME QUESTIONS! I came into the support call with FACTS. Same exact issue. Ring Doorbell 2 not showing “Hardwired”. Worked fine prior but I got sick of the battery dying and not capturing anything. Yes the battery lasted quite a long while but once it stops, it stops. So installed transformer, getting 19.88Vac at the transformer. 19.14Vac at the screws. When it was first connected, the Ring Doorbell went to “Hardwired” so great! Checked it the next day, back to battery. Never went hardwired ever again. I have tried endless things to fix the issue. Bought the Ring Wirewound Resistor for $12 shipped. Nothing causes it to go Hardwired. The Doorbell is definitely NOT trickle charging. I live in a cul-de-sac and get hardly no activilty and the battery still discharges. After all that time spent on the phone with Ring Support and absolutely no further along then when I began the call. I am completely disenchanted with Ring. This is clearly a hardware/software issue and all they cared about is me sending them a picture of how I have mounted it!!! SERIOUSLY! And answer a couple of questions they already covered with me on the phone! This clearly was a diversion tactic to get me off the phone after they exhausted everything they could think of. You know what boils my blood even more? Ring Support tried to tell me that even if it is Hardwired it will show it’s in Battery mode…if the Doorbell experiences activity. Are you kidding me! There is a reason they have the two modes, “Battery” and “Hardwired”, so you can tell what mode it is in! So please tell me why it’s not charging! Explain that away too. They said, if there is too much activity the trickle charge can’t keep up with the discharge. Ok, I can understand that to some extent, but that is not the case here! The issue is with the HW/SW!!! And Ring does not want to own up to it. Worthless. This is why people will slowly move to another Video Doorbell brand. Because all Ring Support does is waste your time and then send you on your way when you have lost all hope they will do the right thing! I’M TALKING TO YOU RING SUPPORT MAN IN ARIZONA AND ALL OF RING/GOOGLE/ALPHABET.