Ring Doorbell 2 and Ring Spotlight Camera wifi connection issues

We just switched from Cox to AT&T fiber and had to change our wifi SSID. I’ve tried connecting both the Ring Doorbell 2 and Ring Spotlight Camera (solar powered) to the new network but both devices fail to connect in the app. I’ve attached a screenshot of the error page.

I’ve factory reset both devices, disabled AT&Ts packet filter and firewall completely, I even tried connecting the ring devices to my Verizon phone Hotspot but still getting the same error. Really need assistance as both devices are now offline.

Thank you

After fiddling with settings, putting an Eero mesh right next to the ring devices, I installed the ring app on my work phone, logged in, and instead of trying to change the wifi network of my devices already been setup, I went to add new device and my work phone was able to connect the ring doorbell and spotlight camera to my wifi. Not sure if it was due to me trying it on a different device (my work phone), or trying to setup new device rather than change wifi on already setup device. Figured I’d leave this up for anyone who runs into a similar issue.

Hey @NITRO2. Since you have done a hotspot test and this was to no avail, I recommend following up with our support team on this concern if you have not already. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.