Ring Doorbell 2 (2020) not completing setup

Hi everyone, my ring doorbell 2, which i bought in November 2020 and was working perfectly before, said it was not connecting to the internet, so i did what it said in the app to connect it to the internet. However afterwards it says it can’t connect to the internet and now whenever you press the button, it rings in at a low volume and flashes the blue light 5 times. When i checked my internet hub menu, the ring doorbell is connnected to it. So when i tried calling support, it says it has closed at 8 even though I called at 7pm.

Thanks for any help

Hi @VinoI. Have you tried resetting your Doorbell? If not, I’d recommend resetting it by holding down the setup button for at least 20 seconds. Once that’s done, you’ll need to set it back up in the Ring App by following the steps under Set Up a Device. This should walk you through reconnecting it to the internet, and it should connect without issue. Should this concern still persist after trying a reset, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.