Ring base station fails to connect with wifi hotspot

I’ve spent many frustrating hours trying to get the Ring devices to work with a hotspot based on an iPhone. Sometimes it works and sometimes it doesn’t. Most recently, I thought I would take use a better iPhone (an 8) to use as the hotspot as the previous one was an iPhone 6 (which I eventually got the Ring base station and the Ring indoor camera to work with, but it had a bad battery and wouldn’t hold a charge).

I switch the SIM, change the iPhone name to the same I was using with the older phone and restarted the new iPhone. I logged onto the new iPhone hotspot with a different phone. Everything checked out. I could use the hotspot to browse the web.

I then put the base station in pairing mode and tried to change the hotspot as it wasn’t automatically seeing it. The new hotspot came up on the base station list and I selected it and gave it the password. Despite trying this several times, the base station eventually refused to connect. It would try for perhaps a couple minutes or more and sometimes I’d see a blue flash on the base station, but then it would go back to the white lights pulsing before giving up.

I don’t really understand what is going on. All I know is that it is far more of a struggle to get the Ring devices to play nice with wifi than it should be. They seem overly temperamental.

Hi @Sausalitoman. Try performing a reboot on your Base Station. You can do this by briefly tapping the Reset Button on the back of the Base Station using a paperclip or something similar. Be sure to only tap this button and not hold it down, as that may initiate a factory reset. Once the Base Station reboots, you should be able to connect it to WiFi.

If you still have issues after that, it would be best to reach out to our Ring Alarm Support team for the next best steps. Please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

1 Like

I think the hard reset would have worked, but I fixed it by changing the name of the hotspot to something new (instead of keeping it the same as the old hotspot). That forced the ring station and camera to use the new hotspot’s info to connect. For some reason, if you introduce a new hotspot device using the same name as the old hotspot device, the Ring devices will hang onto the old info and you won’t connect. All is working now.

1 Like

Hey @Sausalitoman. That is interesting! I’m glad you were able to figure this out. I’ll pass this information along to be looked into!