Ring Base Station Connects to Wifi but Not Ethernet

I noticed last night when I went to set my Ring security system to “Home” that the base station was working off of cellular backup. The base station has always been connected to ethernet and is located 1 foot away from my router. All other devices plugged into my router still (ie: Apple TV and wifi) worked perfectly.

I went through the usual list of trying different ethernet cables and different ethernet ports on my router/switch and none of them solved the issue. I also used the app to try to reconnect to ethernet - although the base station could be found via bluetooth pairing, no matter what I did, the base station could not be found when connected via ethernet. I was able to connect the base station via wifi without any issues. However, I’d much prefer that Ring be connected to ethernet for both bandwidth and security reasons.

Any ideas on why the base station will connect to wifi but not ethernet? If I factory reset the base station, will I have to add all of my security devices back in (doorbell, various cameras, sensors, etc)?

Did you try Reboot Base Station in the Advanced Settings in the Ring App?

Wow, that totally did the trick! Thanks a bunch!

2 Likes