Ring app on IOS not working correctly after latest software update

Since the latest Ring app update on my iPad, it now struggles to display or connect to my Ring Pro doorbell live video…

There have been 2 updates to the app recently (the latest being on the 17th of April) and when motion/door bell is triggered, it attempts to load the live video and gives the “Activating Device” message and rotating blue circle but eventually fails.

I have also noticed the app is very sluggish and seems to freeze but then jumps to life. If I manually go to live feed, it will eventually do it.

The previous software version worked a treat but now for whatever reason, it doesn’t.

I have the Ring Pro with up to date firmware and is showing good health and a very decent WIFI signal.

I am using an old iPad (4th gen) with IOS 10.3.4. I have been using this device to solely provide video from the Ring app and it has worked without issues now for nearly a year. I have tested other apps to see if it is an iPad memory issue but all is working fine. It just seems the new Ring app update does not want to work on my device anymore. I cannot install Rapid Ring app either because that requires IOS 12 or later.

Any suggestions that do not involve spending money on a new iPad would be very much appreciated.