Ring app doesn't start after latest Windows 10 Pro N update version 1903 OS build: 18362.295

Hi there,

I updated my Windows 10 and after rebooting Live view stopped working on all my cameras, reinstalled the Ring app and it got worst. Now it doesn’t even start, I just get the “something went wrong” pop up with error code 0x80040154. I ran the reset command on the Windows store and re-registered all apps from the MS Store and no change, rebooted many times and checked the windows 10 has the latest update and still get the error pop up.

I have Windows 10 Pro N, update version 1903 OS build: 18362.295, updated on 8/29/2019 and checked today and still up to date on updates. This is a Macbook pro with a Windows partition. The Ring app still works when I boot up on the Apple OS and my phone app works too.

Thanks for any guidance.


Live View worked for me in Windows 10 Pro v1809.
I just updated to Windows 10 v1903, and Live View continues to work.

It takes a little longer to connect and display though.
I have a Ring Pro.

Turn on the “Let app send crash reports” in your Windows Ring app.

Ahh, I can’t even get to a point where I can change the settings in the app, first thing that comes up is the “something went wrong message” and after that the only option is to close that window. I don’t even see the login window or anything else like a menu option, etc.

Hi neighbors! We did some research and found this post in the Microsoft Community. We have sent this information and post to the team for further investigation. Thank you!

Followed the link and downloaded and ran the Windows Update troubleshooter and no issues found, also got new Windows 10 udates today and they completed succesfully and the Ring app still doesn’t start, still with the same error. Uninstalled the Ring app and reinstalled after the latest windows update and no luck still doesn’t work past the window that says “something went wrong…” same error code as before.

OS Name Microsoft Windows 10 Pro N

Version 10.0.18362 Build 18362

I think thit is not a problem unique to the Ring app, I noticed some of the applications from the MS Store don’t work anymore like Facebook and some free games that use the microphone and/or video chat, but others like Spotify, Netflix, VLC and Adobe reader work as usual, maybe apps that need access to the microphone or built in camera fail while others that don’t need access to those work.

1 Like

Fixed the issue myself, figured out the Windows >>>N<<<< version needs a feature pack to run the camera and mic, I probably did it a long time ago but when the 1903 build got installed a few weeks ago it didn’t install that pack and no matter how many times you check windows update it won’t get it, you have to find it in the microsoft downloads and install it manually again, it has to match the OS build number. After installing and rebooting it the Ring app works again.

1 Like