Ring app does not accurately reflect battery charge

I have installed a fully charged battery in my Ring Spotlight camera and app shows 10% charge. I have uninstalled and re-installed the app and still get same low charge. Anyone else experienced this?

Hi @JetBlue! When you take the battery that you just put into the camera out, plug it into the charger provided, are the lights on the battery orange and green or just solid green? If the colors are orange and green, the battery will still need to be charged. Please note that most charging takes about 8 hours to give it full power. I would also recommend that if you have another battery, see if that battery, when fully charged, shows properly in the app!

Thanks for your response, @Chelsea_Ring. When I put the battery in the camera, the light was just green. I will try another fully charged battery and will update here with results.

1 Like

I’m having the same problem. I have 2 batteries. When replacing with a fully charged battery indicator On my app shows only 19% low battery.

1 Like

Mine is doing the same thing. I have 2 batteries one of which is only a month old. Obviously a small glitch in the app as the email notifications about battery life take weeks to come through. Battery status shows 18% constantly.

I am experiencing the same problem. I have 2 batteries in my Ring Spotlight. Both batteries are fully charged. However one battery is showing 100% and the other battery is showing 56%. Does anyone have suggestions on how to fix the problem?

I’m having the same issue. Android app shows 15-18% constantly but the Windows app shows much higher, sometimes 100%.

Thank you for pointing this out neighbors. Can you please send over what app version and phone you are using? Thank you!

We are having the same problem with our driveway cam. The battery is fully charged, but shows only 26% charged on the app.

Hi, I have the same incorrect battery life issue. The Ring app version is 5.272 on an iPhone XS with iOS 13.5.1.

Thanks.

iPhone 8
App version 5.27.2
Battery indicator stuck at 19% even with a full charge

1 Like

battery says 92% for 3 days yet i have solar panel???

1 Like

Same problem here. Up to date Ring app, tried two different batteries both fully charged with all green light on after charging and the Ring Doorbell 2 refuses to update the battery life and restore fucntions. It is at 6% to frustrating as it has disabled a bunch of features due to low battery despite having a fully charged battery installed. Problem started to occur on 14th July.

ios app version: 5.28.0 (updated on 15th July)

Firmware version: ‘Up to date’

Last health check: 8.12pm BST on 7th July

1 Like

Thank you, neighbors! I’ll get this information over to the team right away. I’m assuming when everyone says “the battery it as full charge” that means that you let the battery charge for at least 6-8 hours / overnight? Just wondering where you are seeing ‘full charge’ :slight_smile:

Hi I have iPhone 11 on iOS 13.6 and ring app is version 5.28.0
My battery again does the same fully charged battery installed and still shows on the app the 31% from the old battery ? Please help

I am having issues with one of my ring camera for past few days. I have extra spare batteries and one of my cameras indicated low battery. I replaced the battery and the camera never recognized it and still said low batteries. Just to check I had 3 other freshly charged batteries to test as well and same thing happen. Wondering if something in the camera is bad or software to make camera recognize battery is full to work correctly.

It is disapointing that this happend to a camera that is only 4 months old. Ring Support on the phone was not helpful at all when I asked if I should get a replacement to fix the issue. Very frustrated…

1 Like

Jennifer.
Did you get an answer to this question? My battery level does not update on the App either.
Carl

I’m having the same issue. Mine was showing 8% when I went to bed last night and said the same this morning when I woke up. I’ve tried changing chargers and cables thinking that could be the issue, but don’t think it is. The blue light around the button seems to indicate the batter is charged.

I’m having the same issue. Battery was at 13%. Put in fully charged battery and the app is still showing 13%.

Hi neighbors. Chiming in here with some helpful tips. Once your battery is fully charged (green LED on battery), reconnect your device to wifi. Establishing a new wifi connection will force your device to go through a quick update and it should reflect the correct battery percentage once complete. To do this, follow the steps here in this Help Center article. Let me know if this works!

1 Like