Ring Alarm is offline after setup

Hi all,

I’m configuring my Ring alarm base station for the first time, and after selecting my Wi-Fi network and getting a success notification, the device is marked as offline in the app. Not sure if I’m doing anything wrong, so I recorded a video with the process I’m following, in case I missed anything. Can be watched here: Cloudup.

In case the video goes too fast, these are the steps I’m following:

  • Tap the “Ring Alarm is offline” notification.
  • Tap “Retry connection”.
  • Nothing happens.
  • Tap “Still can’t connect”.
  • Tap “Join Network”.
  • Tap “Continue”.
  • Press the pairing mode of the Base station.
  • The light ring starts to spin.
  • Tap “Find my base station”.
  • My base station is found and I’m ask to select a way of connecting to Internet.
  • Tap “Wi-Fi”.
  • Tap my Wi-Fi network.
  • The device apparently connects successfully to internet, but it still appears as offline.

Thanks for the help in advance.

Hi @mmtr. Thanks for attaching a video example as well as listing out what steps you’re running through. Just to make sure, is your Ring App fully up to date? You can check for any applicable updates in your phone’s app store. After you walk through these steps and it says it is connected, what color lights do you see on the back of the Base Station, where the wifi and power LEDs are at? Feel free to attach a picture of this as well. I may end up suggesting you contact our support team on this concern, but I’ll see if I can offer any helpful suggestions once I know what color those lights are. :slight_smile:

Hi @Caitlyn_Ring. Yeah, the app is updated. And the rear LED indicators are green, for both power and Wi-Fi. Also accessed my router settings via the browser and verified that the base station is connected to the router. Thanks for your help!

@mmtr Thanks for checking on those details for me. The Base Station should definitely be properly connected to the internet then if it’s showing that both the power and WiFi LEDs are lit up in green. In this case I do think it’s best if you give our support team a call when you have a moment, as they may need to do a bit more advanced troubleshooting with you on your Base Station. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Let me know how that call goes and what solution they’re able to suggest. :slight_smile: