Ring Alarm Base Station - Not Available on Web Dashboard

I have a Ring Alarm Base Station (ver. 1.31.0) that is connected via ethernet and shows as available and functioning within the Ring app; however on https://account.ring.com/account/dashboard it displays the following error: “No Ring Alarm: Your Ring Alarm does not seem to be available anymore.”

I have provisioned the base station with a static IP assignment within my local network, and have TCP/UDP port 6970 forwarding to it.

Everything does appear to be functioning properly otherwise - just wanted to make sure that it’s not an issue down the road. I have the Protect Plus plan, and I’m based in Canada.

Hey @praetorr . Do you have a VPN enabled on your computer? If so, try disabling it and see if your Alarm loads after. In the event it still doesn’t load, I recommend double checking with our support team on this, as I am able to see my Base Station and Alarm on Ring.com myself, so you should too! For support and since you’re outside the US, please read our response to COVID-19 here to see how to contact support. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. Feel free to come back and let me know how this goes! :slight_smile:

1 Like

Thanks - I didn’t realize the Ring monitoring applet in the dashboard actually required additional port access. I was attempting to view it from my work network, which was apparently blocking this access (but nothing else - cameras still worked). When I log into the web dashboard from a personal computer, it works as expected.

1 Like