Ring 2 solar charger not charging

Just installed it also, my doorbell is in bright sunlight all afternoon, I thought that was the reason my battery drained so fast, that it got to hot. Just installed it yesterday and I see my charge also going down still, even the app says solar panel installed. Seems it’s engineered for low usage of the cam itself. I think majority here their average current usage from the battery is more then what the solars produce. Would be better if it had more or bigger panels but that would look ugly. Think I’ll have to start drilling and ataching their permanent power supply as this is clearyl under dimensioned. Or @Ring, what voltage is ideal for the ring, might jsut connect a smaller real solar panel on the rofo or shed to keep it charged?

I purchased the 2nd gen solar panel and it had never worked. It looked returned but I was hoping it was because someone changed their mind. I have cleaned everything, took it down, opened it, reassembled, etc… Reading the reviews and knowing this is a recent release, I think it was a bad batch. I have seen so many people say their solar charger does not work.

1 Like

They don’t work at all. I am still waiting for a replacement from Amazon…

1 Like

Just installed the charger on my R2 doorbell, no indication in the device health section that the solar charger is installed. Battery is draining but panel is in full sunlight 8+ hours. I only get about 5 motion detections a day. Looks like I got a bad one. They were running a sale…probably to flush out aomebad product.

Sorry to hear about this experience, neighbors! If the Solar Charger is receiving several hours of direct sunlight and is connected securely to the back of the Video Doorbell, your battery should charge after some time. In addition to limiting the number of events, please also ensure lengthy live view times or wifi signal interference is not also causing battery drain. Our Community post about battery drain covers this and more.

If you feel you’ve checked all of the above variables and this concern persists, feel free to check in with our support team for a further look. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Reply to Marley_Ring Community Manager -

There are dozens of complaints on here from people who have reset and verified that their devices get plenty of sun and don’t have excessive amounts of alerts or poor Wifi. There are likely plenty of other customers with problems who have not posted here. Your reply to this community of customers is quite frankly unhelpful and insulting. There appears to be a product or firmware problem. An earlier post in here from a Ring Community Manager stated that a problem had been introduced in a firmware upgrade a while ago, but supposedly had been corrected. From the recent comments, it appears it is still a problem. In my case, the solar charger worked fine for several months, and now it has not worked for about the last 10 months.

I have an update on my situation. It is now showing that I’m connected to solar which wasn’t showing previously. I’m not sure when it started showing connected, but it is sometime in the last week. I previously had the charger, doorbell and battery all replaced to no avail. I was in agreement with others that it may have been a firmware release that caused the issue. Perhaps it is fixed for others as well?

1 Like

Same here. I was about to call support again to escalate my situation (get a replacement sent) but my Ring Doorbell 2 is suddenly showing Solar Status: Connected.

1 Like

I am on my second solar panel, thinking the first was defective. Problem is that the device gives no indication of whether or not a solar charger is attached, or if it is working. This simple capability would go a long way to dealing with issues. That being said, two solar chargers and it still isn’t working tells me there is a bigger problem here.

I have the same problem with my newly purchased Gen 1 solar charger. At first it seemed to be working and the battery charge stayed above 90% and was beginning to creep up over time.

Then I went away for the weekend (when there were actually no motion notifications due to a lack of visitors), and when I got back the battery is suddenly at 27% and it’s asking to be recharged!! In the device health screen it says the charger is “Established”, whatever that’s supposed to mean.

It’s on a South facing wall and gets several hours of direct sunlight every day. I’m pretty unimpressed at this point. I guess I’ll charge it up again and see what happens, but if it keeps failing I’ll have to send it back

Wholeheartedly agree, I purchased 2. We tried everything too and when we check the battery level we keep seeing this Solar Status “Not Established” god knows how you get it to establish, we’ve tried it all.

My solar panel for the doorbell doesn’t work. I think it drains faster. I have solar on my cameras in similar locations.

Why don’t these work and ring doesn’t support the issue?

I have the same issue!

Something has been updated recently. Mine now says “Established,” but the battery continues to drain.

Yeah I have the same thing happening.

all the hoops you have asked us to jump through do not work! How about a refund based on false advertising???

I have the same problem. My Ring 2 recognizes my solar charger because it says established but it is not charging my battery at all. I wanted to give another chance, removed the battery and fully charged it, but I’m still noticing it to be draining slowly. It is completely exposed to the :sunny:… I don’t understand! It’s frustrating!!!

Mine is not working either and all of the reviews on Amazon have been taken down, shows 3 starts with 645 reviews but can’t see any of them, mine says solor not established, when it get light from sun up to sun down, brand new does not work!! And both of the holiday face plates I orderd arrived broken,

Mine used to work for a couple years. Then it sopped late lat year. Nothing was changed. Next it started showing “add a ring solar charger”. I suspect this was an upgrade to the firmware in the doorbell that allowed it to detect the charger. Maybe three or 4 months ago I called ring and got them to replace the charger (no luck) then the doorbell (again no luck). I even validated that I’m getting power from the solar charger using a multi-meter. Also, I have 2 other batteries in a ring spotlight that is also solar charging and which works great and I swapped batteries. The one I pulled from the spotlight at 100% charge only showed 88% charge in the doorbell and it is now discharging in the doorbell. The one I pulled from the doorbell charged up just fine in the spotlight with solar. Recently (within the last month or so) the doorbell now shows as connected to a solar charger, but it is still not charging. I hope that at some point yet another firmware update will be released so not only will it show as connected but it will actually charge. I will probably have to call them again to see if I can make some more noise.

1 Like

Sure wish something was done to correct this problem. I pretty much spent about a month of my life on phone with them and getting replacement panels and doorbells. Nothing solved the problem. It’s in direct sun for 6+hrs too. No debris and I even worked with a level 2 tech until he stopped calling me back or responding to my messages.